2001 3.8l running rough, help????

Discussion in 'SN95 V6 Mustang Tech' started by valleystang11, Jan 3, 2010.

  1. inspector8

    inspector8 New Member

    Joined:
    Jul 9, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    2
    Location:
    Catoosa, OK
    Pushed back pin

    The BL/GR wire female connector on coil plug was pushed back!!!!!! Thanks sooooooooooo much for your help. I probably still have a bad coil, I'll find out the next time it's hot. It's great AutoZone takes back electrical components, Oreillys won't.

    :):):):):)
     
    #21
  2. MFCstang96

    MFCstang96 New Member

    Joined:
    Dec 15, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    trying to get dads GF back on the road in the stang!

    i need help for a similar issue! car runs rough.. bogs out.. stalls when you come to a complete stop SOMETIMES.. engine shakes at low RPM just like stated above BUT i also have a ticking noise coming from somewhere under or around the intake and before you crank the engine the fuel pump sounds like its spazzing out. seems like a bad connection somewhere? any help? i can take something apart and put it together but no experience with diagnostics. it is a 96stang with an 03v6 in it. car drove fine up until today.

    car is in arizona.. live off of a dirt road.. and is driven no more than 30 miles a day just to give you more of a clue of driving conditions.
     
    #22
  3. wmburns

    SN Certified Technician

    Joined:
    Aug 14, 2009
    Messages:
    3,196
    Likes Received:
    60
    Trophy Points:
    69
    Location:
    Houston Texas
    #23
  4. inspector8

    inspector8 New Member

    Joined:
    Jul 9, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    2
    Location:
    Catoosa, OK
    2003 v6 running rough

    If you read my previous posts, I was really helped by this site. I don't see if you have put a OBD2 tester on car and read the codes. You need to do this first. Autozone + Oreillys both will read your codes for free, or lend you their tester if you can't drive to store. Good luck!:)
     
    #24
  5. MarcusTroy

    MarcusTroy New Member

    Joined:
    Dec 2, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Had a similar problem. Ran rough while accelerating. After months of no shop being able to figure out what was wrong with it, ended up changing the coil pack and it runs like a dream again!
     
    #25
  6. Patsy

    Patsy New Member

    Joined:
    Dec 9, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My '03 6cyl. During a rainstorm started missing, runs rough,& shifts hard. Tester said coil pack, 3 packs later, new plugs,new wires, even new computer, programmed by dealer. Still #3 &4 missing.
    After joining and reading ur forum I checkef o2 sensors...I have 2left and 2 right...at approx $50 each.
    I'm wasting a lot of money troubleshooting this...please advise on my next move. Thank yoi
     
    #26

Share This Page