2010 4.6 Engine miss

Discussion in '2010 - 2014 Specific Tech' started by fattypie, Jun 23, 2011.

  1. fattypie

    fattypie New Member

    Joined:
    Jun 23, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I have a 2010 4.6 with 8000 miles on it. I purchased a 400+HP "top end kit", cams, heads, throttle body and intake from Ford Racing, and had a local Ford dealer install it. The car has a low rpm miss, that dyno tuning, and new spark plugs have not been able to fix. Does anyone have any ideas what is causing this headache for me?

    Vacuum line, injector, cams? Please help.
     
    #1
  2. Svtpilot

    Founding Member

    Joined:
    Jun 16, 2002
    Messages:
    725
    Likes Received:
    52
    Trophy Points:
    29
    Location:
    Long Island, NY
    By low rpm do you mean at idle? The reason I ask is because the FRPP kit you installed includes "hot rod" high lift cams that will give you a rough idle.
    This is from the description from the FRPP catalog:
    This camshaft provides a lopey idle reminiscent of 1960's muscle cars, no other modular camshaft sounds like this.
     
    #2
  3. FordCustSrvc

    FordCustSrvc Active Member

    Joined:
    Oct 25, 2010
    Messages:
    457
    Likes Received:
    26
    Trophy Points:
    29
    Location:
    Dearborn, MI
    Hi fattypie,

    Svtpilot is correct, it may be a feature of the kit you chose. If you are concerned though, I suggest having the dealer who installed it take a look to make sure everything is functioning correctly. Please let me know if I can be of any assistance.

    ~Natasha
     
    #3
  4. SpartaPerformance

    Site Sponsor

    Joined:
    Nov 5, 2006
    Messages:
    2,175
    Likes Received:
    25
    Trophy Points:
    59
    Location:
    Long Island NY
    Do you have a check engine light or any codes? Do you have a recording of the engine?
     
    #4

Share This Page