2010 antilock traction control problems

Discussion in '2010 - 2014 Specific Tech' started by R/T, Mar 30, 2011.


  1. R/T

    R/T New Member

    Joined:
    May 27, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I have a 2010 GT with 21K Auto garaged and well aken care off.
    Now to the problem The traction controal antilock brake lights keep comming on, I have had it to the dealer 3 times now. The first time it was a loose wire on antilock they said. The second time they could not find anything. The 3rd time I was on the was back from the dealer and the lights came on and stayed on for 3 days, they said it was bad battery so they replaced it. Well I got about 30 miles on it after leaveing dealer and it came back on.
    I called the dealer today and they are at a loss they said the tech will have to call Ford hot line but would get back to me befor the day ends, gess what never got a call want to see my suprised look:nono: .
    The brake seem work fine but for how long I know it won't do any good to get pist but it's a 60mile round trip every time.
    Does anyone have any ideas have they had this happen to them?

    Thanks
    Richard
  2. FordCustSrvc

    FordCustSrvc Member

    Joined:
    Oct 25, 2010
    Messages:
    419
    Likes Received:
    20
    Trophy Points:
    19
    Hi Richard,

    This is Deysha with Ford Customer Service. I would like to escalate this for you. Could you message me your VIN, mileage, dealer, and contact info?

    Deysha

Share This Page