4.0 Lean Miss, Frp?

Discussion in '2005 - 2014 Specific V6 Tech' started by GetinSideways, Sep 8, 2013.


  1. GetinSideways

    GetinSideways New Member

    Joined:
    May 12, 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    2
    My 4.0 will flash the engine light under heavy load at high rpm, 5500rpm plus (P0300 code) It did this on rare occasions when it had just a Bama tune. I just put long tubes and a cai on its become a regular thing, I've set the code as low as 4500 rpm in higher gears after running it hard through 2nd and 3rd. Used my livewire to read frp, typically 45 on cruise, 60ish at idle. Normal acceleration 50-55. Hard acceleration 40ish and the light would flash. Changed fuel filter and some inj cleaner I'm seeing lower numbers. Idle is 50ish cruising it hovers over 40, hard throttle I've seen as low as 35. Off throttle high rpm and load I've spiked as high as 75. All this irregularity has me concerned. What's a safe frp? Suspecting my fuel pump.
  2. earleys94gt

    earleys94gt Active Member

    Joined:
    Aug 31, 2003
    Messages:
    1,151
    Likes Received:
    13
    Trophy Points:
    49
    Location:
    Ashley, Ohio
    What condition are your Plug Wires in?

    Friend of mine had a similar issue, and it turned out one of the Plug Wires had started to arc from the inside out.

    Depending on the mileage of the car, you may be needing a fuel pump or "tune up".
  3. GetinSideways

    GetinSideways New Member

    Joined:
    May 12, 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    2
    New plugs and wires and fuel filter. Before I added long tubes it set the code on rare occasions during burnouts, now it's anytime I do a long pull wot 3rd and 4th. Today I finally got it to set a p0301 code I'll do a relative compression test, if all is well I'm prolly gonna through an injector at it.

Share This Page