Electrical 6 Week Long Charging Problem

Discussion in 'Fox 5.0 Mustang Tech' started by Christian Berry, Jun 22, 2014.

  1. Christian Berry

    Christian Berry New Member

    Joined:
    Jun 22, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hey guys i'm new here and i've been trying to solve a charging issue for about 6 weeks now with no luck from any other forums so hopefully someone here can help me. Sorry in advance if this is long but it's all necessary to get a clear view of my problem. I was troubleshooting my car not starting. I had an MSD 6200 box with a blaster 3 coil. While troubleshooting I disconnected the coil wire from the Blaster 3 but left the two small power wires on it. I then put an older regular blaster (the square kind) next to it with the ignition module and coil wire connected to it (i was trying to see if the coil was the culprit). This left the ignition coil adapter hanging loosely and the tower of the blaster 3 bare with the red power wire from the MSD still connected to the battery. I tried to start the car and got the loudest bang I have ever heard in my life. I couldn't hear for about a minute. I couldn't get out quick enough to see what had happened but I could see a small puff of smoke rise from somewhere under the hood. I ended up replacing my MSD box and coil followed by all new plugs and wires. After everything was reconnected the car fired right up but the amp light was on on the dash and the car was not charging. I began troubleshooting and here is a list of what I tested/changed. By the way I am running a 3G setup.

    1. Had alternator bench tested and even torn apart and gone through. Checked out fine.
    2. Had Battery bench tested, also checked out fine
    3. Replaced all fusible links
    4. Battery voltage is at about 12.57 off AND while running
    5. Alternator voltage is ask at about 12.57 on the back stud with the 4 gauge wire on it
    6. Rechecked all the wiring between battery, alternator, MSD, and solenoid relay and all is correct
    7. Had TFI bench tested, also checked out fine
    8. Checked and cleaned all grounds

    I did find a char mark on the resettable breaker for the power windows/locks on the solenoid so from what I can gather, whatever arced hit that and possibly the stud on the solenoid with the alt wire on it. I've gone through about every test I can find on the web to figure this out and still have gotten nowhere. I can't really afford to throw anymore parts at this thing and i'm just about at my wits end. SOMEONE PLEASE HELP!!!!!
     
    #1
  2. modulistic

    modulistic Member

    Joined:
    Nov 27, 2002
    Messages:
    321
    Likes Received:
    19
    Trophy Points:
    19
    I have no idea, sorry. But that's one hell of an interesting story.
     
    #2
  3. Blown88GT

    Founding Member

    Joined:
    Nov 13, 1999
    Messages:
    634
    Likes Received:
    6
    Trophy Points:
    19
    Location:
    Palm Beach Gardens, FL
    3. All you could find. You might have missed Fuselink "E". "E" & "F" are in series.
    4. Indicates not charging, we know that.
    5. Indicates external regulator control signals not working. This is a fuselink or wiring.
    6. Forget MSD, it has nothing to do with charging.
    7. Forget TFI, it has nothing to do with charging.
    [​IMG]
    [​IMG]
     
    #3
  4. jrichker

    jrichker StangNet's favorite TOOL
    SN Certified Technician Founding Member

    Joined:
    Mar 10, 2000
    Messages:
    21,908
    Likes Received:
    411
    Trophy Points:
    134
    Location:
    Dublin GA
    Alternator troubleshooting for 86-93 5.0 Mustangs:

    Never, never disconnect an alternator from the battery with the engine running. The resulting voltage spike can damage the car's electronics including the alternator.



    Revised 15 April 2012 to add simple check for regulator failure in Engine off ignition on, battery fully charged section, item 2.

    Red color text applies to cars with a 3G alternator.

    Do all of these tests in sequence. Do not skip around. The results of each test depend on the results of the previous tests for correct interpretation.

    Simple first step: Remove the alternator and take it to your local auto parts store. They can bench test it for free.


    Use a safety pin to pierce and probe the insulated connectors from the rear when doing tests with the connector plugged into its' mating connector.

    Engine off, ignition off, battery fully charged.
    1.) Look for 12 volts at the alternator output. No 12 volts and the dark green fuse link between the orange/black wires and the battery side of the starter solenoid has open circuited.
    3G alternator: Look for 12 volts at the stud on the back of the alternator where the 4 gauge power feed wire is bolted.
    No voltage and the fuse for the 4 gauge power feed wire is open or there are some loose connections.

    2.) Look for 12 volts on the yellow/white wire that is the power feed to the regulator. No 12 volts, and the fuse link for the yellow/white wire has open circuited.

    Engine off, ignition on, battery fully charged:
    1.) Alternator warning light should glow. No glow, bulb has burned out or there is a break in the wiring between the regulator plug and the dash. The warning light supplies an exciter voltage that tells the regulator to turn on. There is a 500 ohm resistor in parallel with the warning light so that if the bulb burns out, the regulator still gets the exciter voltage.
    Disconnect the D connector with the 3 wires (yellow/white, white/black and green/red) from the voltage regulator.
    Measure the voltage on the Lt green/red wire. It should be 12 volts. No 12 volts and the wire is broken, or the 500 ohm resistor and dash indicator lamp are bad. If the 12 volts is missing, replace the warning lamp. If after replacing the warning lamp, the test fails again, the wiring between the warning lamp and the alternator is faulty. The warning lamp circuit is part of the instrument panel and contains some connectors that may cause problems.

    2.) Reconnect the D plug to the alternator
    Probe the green/red wire from the rear of the connector and use the battery negative post as a ground. You should see 2.4-2.6 volts. No voltage and the previous tests passed, you have a failed voltage regulator. This is an actual measurement taken from a car with a working electrical system. If you see full or almost full12 volts, the regulator has failed.

    Engine on, Ignition on, battery fully charged:
    Probe the green/red wire from the rear of the connector and use the battery negative post as a ground. You should see battery voltage minus .25 to 1.0 volt. If the battery measured across the battery is 15.25 volts, you should see 14.50 volts

    Familiarize yourself with the following application note from Fluke: See http://assets.fluke.com/appnotes/automotive/beatbook.pdf for help for help troubleshooting voltage drops across connections and components. .

    [​IMG]
    You will need to do some voltage drop testing of several of the wires.

    Start looking for these things:
    1.) Bad diode(s) in the alternator - one or more diodes have open circuited and are causing the voltage to drop off as load increases. Remove the alternator and bench test it to confirm or deny this as being the problem.

    2.) The secondary power ground is between the back of the intake manifold and the driver's side firewall. It is often missing or loose. It supplies ground for the alternator, A/C compressor clutch and other electrical accessories such as the gauges. Do the voltage drop test as shown in the Fluke tech note link. Measure the voltage drop between the alternator frame and the battery negative post. Watch for an increase in drop as the load increases. Use the Fluke voltage drop figures as guidelines for your decisions.

    3.) Bad regulator that does not increase field current as load increases. Remove the alternator and bench test it to confirm or deny this as being the problem.

    4.) Bad sense wire - open circuit in sense wiring or high resistance. The yellow/white wire is the voltage sense and power for the field. There is a fuse link embedded in the wiring where it connects to the black/orange wiring that can open up and cause problems. Disconnect the battery negative cable from the battery: this will keep you from making sparks when you do the next step. Then disconnect the yellow/white wire at the alternator and the green fuse link at the starter solenoid/starter relay. Measure the resistance between the alternator end of the yellow/white wire and the green fuse link: you should see less than 1 ohm. Reconnect all the wires when you have completed this step.

    5.) Bad power feed wiring from the alternator. Use caution in the next step, since you will need to do it with everything powered up and the engine running. You are going to do the Fluke voltage drop tests on the power feed wiring, fuse links and associated parts. Connect one DMM lead to the battery side of the starter solenoid/starter relay. Carefully probe the backside of the black/orange wire connector where it plugs into the alternator. With the engine off, you should see very little voltage. Start the engine and increase the load on the electrical system. Watch for an increase in drop as the load increases. Use the Fluke voltage drop figures as guidelines for your decisions.


    [​IMG]


    Alternator wiring circuit
    Notice the green wire connects to a switched power source. The circuit contains a 500 ohm resistor in series between the switched power and the alternator. Connecting it to switched power keeps the regulator from drawing current when the engine is not running. The resistor limits the current flowing through the wire so that a fuse isn't needed if the wire shorts to ground.

    Also notice the sense wire connects to the starter solenoid and it is fused. It connects to the starter solenoid so that it can "sense" the voltage drop across the output wiring from the alternator.

    Replacement parts:
    14 gauge fuse link for stock alternator.

    Bussman BP/FL14 Fusible link
    AutoZone

    Dorman - Conduct-Tite 14 Gauge Fusible Link Wire Part No. 85620
    Advance auto parts #85620
    Pep Boys - SKU #8637594
     
    #4

Share This Page