Electrical 67 Mustang Won't Turn Off

Discussion in 'Classic Mustang Specific Tech' started by Rmoore45, Nov 15, 2013.


  1. Rmoore45

    Rmoore45 Member

    Joined:
    Jun 5, 2011
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    17
    67 mustang with a 289 and original wiring harness will not turn off with the key. I replaced the ignition switch and the starter solenoid. Any ideas? I'm working on removing the wiring harness and figuring out the problem but any thoughts would be appreciated
     
    #1
  2. horse sence

    horse sence Please don't call me Mom SN Certified Technician

    Joined:
    Nov 30, 1999
    Messages:
    4,127
    Showcase:
    164
    Albums:
    5
    Likes Received:
    687
    Trophy Points:
    163
    Location:
    Wile Coyote's stunt double
    are you running a single wire alternator ? one without a diode will keep running
    when the key is turned off ,found that out on my ski boat.
     
    #2
  3. Rmoore45

    Rmoore45 Member

    Joined:
    Jun 5, 2011
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    17
    Ended up being the starter solenoid, the I side of the solenoid was hot all the time. I thought I ruled that out when I replaced it a week ago. I didn't need to remove the gauge cluster, a/c duct work, and a good portion of the wiring harness :dammit: :doh:. Now to put it all back together :bang:
     
    #3
  4. Rmoore45

    Rmoore45 Member

    Joined:
    Jun 5, 2011
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    17
    Put everything back together and everything works! My baby is back on the road again. Also fixed a few things while I was in there like a/c duct work and wires that had 3 butt splices etc.
     
    #4

Share This Page