95 Mustang Gt Won't Start

Discussion in '1994 - 1995 Specific Tech' started by dilfer1992, Jul 15, 2014.


  1. dilfer1992

    dilfer1992 New Member

    Joined:
    Jul 15, 2014
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Camp Lejeune, nc
    Just the other day I was at a red light and when it turned green I started to go and out of no where with no warning my car just dies on me. Doesn't start back up at all. At first thought it was a fuel problem so I replaced the fuel pump. That didn't work. You can smell the gas as you crank the car. Next after reading forums I came to the conclusion that the distributor was bad. Replaced it in the same exact spot I removed it. Still does not crank. Please help
     
    #1
  2. davis3

    davis3 Active Member

    Joined:
    May 7, 2006
    Messages:
    1,335
    Likes Received:
    50
    Trophy Points:
    49
    Location:
    CA
    Check the codes and report back.

    At the end of your description, when you say "still does not crank", do you mean the engine rotates and does not start, or it does not rotate at all.
     
    #2
  3. dilfer1992

    dilfer1992 New Member

    Joined:
    Jul 15, 2014
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Camp Lejeune, nc
    it rotates and does not start
     
    #3
  4. dilfer1992

    dilfer1992 New Member

    Joined:
    Jul 15, 2014
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Camp Lejeune, nc
    checked the codes the other day after it broke down and its not throwing anything
     
    #4
  5. davis3

    davis3 Active Member

    Joined:
    May 7, 2006
    Messages:
    1,335
    Likes Received:
    50
    Trophy Points:
    49
    Location:
    CA
    Check for fuel and spark.
    which is missing?
     
    #5
  6. madspeed

    madspeed Colonel Mustard Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    8,501
    Showcase:
    9
    Albums:
    1
    Likes Received:
    1,242
    Trophy Points:
    174
    Location:
    a van down by the river
    Thread moved to the sn95 section where more folks will chime in
     
    #6
  7. madspeed

    madspeed Colonel Mustard Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    8,501
    Showcase:
    9
    Albums:
    1
    Likes Received:
    1,242
    Trophy Points:
    174
    Location:
    a van down by the river
    And, welcome to stangnet!
     
    #7
  8. toyman

    toyman SN Certified Technician

    Joined:
    Jul 20, 2007
    Messages:
    1,855
    Likes Received:
    45
    Trophy Points:
    49
    Location:
    Vernon BC
    The correct DTC port is in the engine bay passenger side NOT under the dash. You should at least get a 111 pass code. Clean the MAF sensor element with MAF cleaner or equivalent. Was the replacement distributor a reman? They are known to be bad out of the box as the PIP sensor is often not replaced. Pull the vacuum line at the fuel pressure regulator. If you see or smell gas at the vacuum nipple the regulator needs to be replaced.
     
    #8
  9. dilfer1992

    dilfer1992 New Member

    Joined:
    Jul 15, 2014
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Camp Lejeune, nc
    if the fuel pressure regulator is ad will that keep it from running? i feel like i smelt gas at the vacuum nipple but was not completely sure. i didnt see gas but felt like i smelt it. is there not suppose to be any gas at all in it?
     
    #9
  10. VibrantRedGT

    VibrantRedGT "STANGNET'S PENGUIN SMACKER" Super Mod

    Joined:
    Nov 30, 1999
    Messages:
    15,569
    Likes Received:
    221
    Trophy Points:
    114
    Location:
    Boca Raton, Florida
    Adjustable fuel regulator is vacuum based there is no fuel in it.

    When you turn the key on (don't start it), can you hear the fuel pump come on? If not that's your problem.
     
    #10
  11. dilfer1992

    dilfer1992 New Member

    Joined:
    Jul 15, 2014
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Camp Lejeune, nc
    it has a new fuel pump in it and yes it does turn on. but i did kinda smell gas in the fuel regulator
     
    #11
  12. jrichker

    jrichker StangNet's favorite TOOL SN Certified Technician Founding Member

    Joined:
    Mar 10, 2000
    Messages:
    21,815
    Likes Received:
    402
    Trophy Points:
    134
    Location:
    Dublin GA
    Cranks OK, but No Start Checklist for Fuel Injected Mustangs

    A word about this checklist before you start: it is arranged in a specific order to put the most likely failure items first. That will save you time, energy and money. Start at the top of the list and work your way down. Jumping around will possibly cause you to miss just what you need to see to find and fix the problem. Don’t skip any steps because the next step depends on the last step working correctly.


    Revised 12-Dec-2011 to replace 10 pin salt & pepper connector graphic.

    All text applies to all models unless stated otherwise.

    Note: 94-95 specific changes are in red

    1.) Remove push on connector (small red/blue wire) from starter solenoid and turn ignition switch to the Run position. Place car in neutral or Park and set the parking brake. Remove the coil wire from distributor & and hold it 3/8” away from the engine block. Jumper the screw to the big bolt on the starter solenoid that has the battery wire connected to it. You should get a nice fat blue spark.
    Most of the items are electrical in nature, so a test light, or even better, a voltmeter, is helpful to be sure they have power to them.

    No spark, possible failed items in order of their probability:
    A.) MSD or Crane ignition box if so equipped
    B.) PIP sensor in distributor. The PIP sensor supplies the timing pulse to trigger the TFI and injectors. A failing PIP sensor will sometimes let the engine start if the SPOUT is removed. See paragraph 5A – Using a noid light will tell if the PIP is working by flashing when the engine is cranking.
    C.) TFI module: use a test light to check the TFI module. Place one lead of the test light on the red/green wire on the ignition coil connector and the other lead on the dark green/yellow wire on the ignition coil connector. If the TFI is working properly, the test light will flash when the engine is cranked using the ignition switch.
    D.) Coil
    E.) No EEC or computer power - EEC or computer relay failure
    86-93 models only: EEC relay next to computer - look for 12 volts at the fuel injector red wires.
    94-95 models only: EEC or PCM power relay in the constant control relay module. Look for 12 volts at the fuel injector red wires.
    Both 86-93 and 94-95 models: No 12 volts with the ignition switch in the run position on the fuel injector red wires. The relay has failed or there is no power coming from the ignition switch. Make sure that there is 12 volts on the red/green wire on the coil before replacing the relay.
    F.) No EEC or computer power - fuse or fuse link failure
    86-93 models only: Fuse links in wiring harness - look for 12 volts at the fuel injector red wires. All the fuse links live in a bundle up near the starter solenoid. Look for a 20 gauge blue fuse link connected to 2 black/orange 14 gauge wires.
    94-95 models only: 20 amp EEC fuse in the engine compartment fuse box. Look for 12 volts at the fuel injector red wires.
    G.) Ignition switch - look for 12 volts at the ignition coil red/lt green wire. No 12 volts, blown fuse link or faulty ignition switch. Remove the plastic from around the ignition switch and look for 12 volts on the red/green wire on the ignition switch with it in the Run position. No 12 volts and the ignition switch is faulty. If 12 volts is present in the Run position at the ignition switch but not at the coil, then the fuse or fuse link is blown.
    Note: fuses or fuse links blow for a reason. Don’t replace either a fuse or fuse link with one with a larger rating than stock. Doing so invites an electrical fire.
    Ignition fuse links may be replaced with an inline fuse holder and 5 amp fuse for troubleshooting purposes.
    94-95 models only: Check inside fuse panel for fuse #18 blown – 20 amp fuse
    H.) Missing or loose computer power ground. The computer has its own dedicated power ground that comes off the ground pigtail on the battery ground wire. Due to it's proximity to the battery, it may become corroded by acid fumes from the battery.
    In 86-90 model cars, it is a black cylinder about 2 1/2" long by 1" diameter with a black/lt green wire.
    In 91-95 model cars it is a black cylinder about 2 1/2" long by 1" diameter with a black/white wire.
    You'll find it up next to the starter solenoid where the wire goes into the wiring harness
    I.) Computer. Don’t replace the computer just because you don’t understand how it works. Computers seldom fail, it usually is a sensor or wiring problem that causes the problems.
    J.) Bad or missing secondary power ground. It is located between the back of the intake manifold and the driver's side firewall. It supplies ground for the alternator, A/C compressor clutch and other electrical accessories such as the gauges.
    K.) Engine fires briefly, but dies immediately when the key is released to the Run position. Crank the engine & when it fires off, pull the small push on connector (red/blue wire) off the starter relay (Looks like it is stuck on a screw). Hold the switch in the crank position: if it continues to run there is a problem with either the ignition switch or TFI module. Check for 12 volts at the red/green wire on the coil with the switch in the Run position. Good 12 volts, then replace the TFI. No 12 volts, replace the ignition switch.

    Wiring Diagrams:

    See the following website for some help from Tmoss (diagram designer) & Stang&2Birds (website host) for help on 88-95 wiring Mustang FAQ - Engine Information Everyone should bookmark this site.

    Ignition switch wiring
    http://www.veryuseful.com/mustang/tech/engine/images/IgnitionSwitchWiring.gif

    Fuel, alternator, A/C and ignition wiring
    http://www.veryuseful.com/mustang/tech/engine/images/fuel-alt-links-ign-ac.gif

    Complete computer, actuator & sensor wiring diagram for 88-91 Mass Air Mustangs
    http://www.veryuseful.com/mustang/tech/engine/images/88-91_5.0_EEC_Wiring_Diagram.gif

    Complete computer, actuator & sensor wiring diagram for 91-93 Mass Air Mustangs
    http://www.veryuseful.com/mustang/tech/engine/images/91-93_5.0_EEC_Wiring_Diagram.gif

    Complete computer, actuator & sensor wiring diagram for 94-95 Mass Air Mustangs
    http://www.veryuseful.com/mustang/tech/engine/images/94-95_5.0_EEC_Wiring_Diagram.gif


    AutoZone wiring diagrams: You can navigate to the diagrams yourself via Repair Info | AutoZone.com and select the car year, make, model and engine. That will enable you to bring up the wiring diagram for your particular car.

    2.) Spark at coil wire, pull #1 plug wire off at the spark plug and check to see spark. No spark, possible failed items in order of their probability: [/b]
    A.) Moisture inside distributor – remove cap, dry off & spray with WD40
    B.) Distributor cap
    C.) Rotor
    D.) Spark Plug wires
    E.) Coil weak or intermittent - you should see 3/8" fat blue spark with a good coil

    3.) Spark at spark plug, but no start.
    Next, get a can of starting fluid (ether) from your local auto parts store: costs a $1.30 or so. Then pull the air duct off at the throttle body elbow, open the throttle, and spray the ether in it. Reconnect the air duct and try to start the car. Do not try to start the car without reconnecting the air duct.

    Two reasons:
    1.) If it backfires, the chance for a serious fire is increased.
    2.) On Mass Air cars, the computer needs to measure the MAF flow once the engine starts.
    If it starts then, you have a fuel management issue. Continue the checklist with emphasis of fuel related items that follow. If it doesn’t, then it is a computer or timing issue: see Step 4.

    Clue – listen for the fuel pump to prime when you first turn the ignition switch on. It should run for 2-4 seconds and shut off. To trick the fuel pump into running, find the EEC test connector and jump the connector in the Upper RH corner to ground. The EEC connector is near the wiper motor and LH hood hinge.

    [​IMG]

    If the relay & inertia switch are OK, you will have power to the pump. Check fuel pressure – remove the cap from the Schrader valve behind the alternator and depress the core. Fuel should squirt out, catch it in a rag. Beware of fire hazard when you do this. In a pinch, you can use a tire pressure gauge to measure the fuel pressure. It may not be completely accurate, but you will have some clue as to how much pressure you have. If you have any doubts about having sufficient fuel flow/pressure, rent a fuel pressure test gauge from the auto parts store. That will tell you for sure if you have adequate fuel pressure.


    4.) No fuel pressure, possible failed items in order of their probability:
    A.) Tripped inertia switch – Coupe & hatch cars hide it under the plastic trim covering the driver's side taillight. Use the voltmeter or test light to make sure you have power to both sides of the switch
    B.) Fuel pump power relay – located under the driver’s seat in most stangs built before 92. On 92 and later model cars it is located below the Mass Air Flow meter. Look for 12 volts at the Pink/Black wire on the fuel pump relay.
    C.) Clogged fuel filter
    D.) Failed fuel pump
    E.) 86-90 models only: Blown fuse link in wiring harness. Look for 12 volts at the Orange/Lt Blue wire on the fuel pump relay.
    91-93 models only Blown fuse link in wiring harness. Look for 12 volts at the Pink/Black wire on the fuel pump relay.
    The fuse links for all model years 86-93 live in the wiring harness near the starter solenoid.
    94-95 models only: 20 amp fuel pump fuse in the engine compartment fuse box. Look for 12 volts at the Dark green/yellow wire on the constant control relay module.
    F.) Engine seem to load up on fuel and may have black smoke at the tailpipe. Fuel pressure regulator failed. Remove the vacuum line from the regulator and inspect for fuel escaping while the pump is running. If fuel is coming out the vacuum port, the regulator has failed. Check the regulator vacuum line for fuel too. Disconnect it from the engine and blow air though it. If you find gas, the regulator has failed.

    5.) Fuel pressure OK, the injectors are not firing.
    A.) The PIP sensor in the distributor tells the computer when to fire the injectors. A failing PIP sensor will sometimes let the engine start if the SPOUT is removed.
    A noid light available from any auto parts store, is one way to test the injector circuit to see if the injectors are firing. The noid light plugs into the fuel injector harness in place of any easily accessible injector. Plug it in and try to start the engine: it will flash if the injector is firing.

    I like to use an old injector with compressed air applied to the injector where the fuel rail would normally connect. I hook the whole thing up, apply compressed air to the injector and stick it in a paper cup of soapy water. When the engine cranks with the ignition switch on, if the injector fires, it makes bubbles. Cheap if you have the stuff laying around, and works good too.
    B.) Pull an injector wire connector off and look for 12 volts on the red wire when the ignition switch is on.
    C.) No power, then look for problems with the 10 pin connecter (salt & pepper shakers at the rear of the upper manifold).

    See the graphic for the 10 pin connector circuit layout.
    [​IMG]
    The injector power pin is the VPWR pin in the black 10 pin connector.


    D.) No power and the 10 pin connections are good: look for broken wiring between the orange/black wire on the EEC relay and the red wire for the 10 pin connectors.
    E.) TPS voltage exceeds 3.7 volts with the throttle closed. This will shut off the injectors, since the computer uses this strategy to clear a flooded engine. Use a DVM, a pair of safety pins, and probe the black/white and green wires to measure the TPS voltage.
    On a 94-95 Mustang, probe the black/white and grey/white wires to measure the TPS voltage.
    It should be .5-.1.0 volts with the key on, engine not running. Note that if the black/white wire (signal ground) has a bad connection, you will get some strange readings. Make a second measurement using the battery post as the ground to eliminate any ground problems. If the readings are different by more than 5%, you may have a high resistance condition in the black/white signal ground circuit.

    6.) Spark & fuel pressure OK.
    A.) Failed IAB or improperly set base idle (no airflow to start engine). Press the throttle ¼ way down and try to start the car. See the "Surging Idle Checklist for help with all your idle/stall problems.
    B.) Failed computer (not very likely)
    C.) Engine ignition or cam timing off: only likely if the engine has been worked on recently. If you removed the distributor, there is a good probability that you installed it 180 degrees out of time.
    D.) Firing order off: HO & 351 use a different firing order from the non HO engines.
    HO & 351W 1-3-7-2-6-5-4-8
    Non HO 1-5-4-2-6-3-7-8
    E.) No start when hot - Press the throttle to the floor & try starting it if you get this far. If it starts, replace the ECT.
    F. ) Engine that has had the heads off or valves adjusted. Do a compression test to make sure the valves are not adjusted too tight. You should have a minimum of 90 PSI on a cold engine.
     
    #12
  13. dilfer1992

    dilfer1992 New Member

    Joined:
    Jul 15, 2014
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Camp Lejeune, nc
    okay so i have replaced the distributor and the ignition coil and all the plugs and wires and for some reason is still isnt getting spark. any thoughts?
     
    #13
  14. toyman

    toyman SN Certified Technician

    Joined:
    Jul 20, 2007
    Messages:
    1,855
    Likes Received:
    45
    Trophy Points:
    49
    Location:
    Vernon BC
    As you know you need three things for the engine to run, air, fuel and spark. Besides replacing certain parts what and how have you tested for the presence of these three items? How have you tested for spark? How have you tested for fuel including the pulsing of the injectors and finally the air mass? Broken wires or failed parts need to be ruled out. Have you pulled the DTCs? I didn't see in earlier posts whether this has been done or not. If so, what were the codes?
     
    #14
  15. dilfer1992

    dilfer1992 New Member

    Joined:
    Jul 15, 2014
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Camp Lejeune, nc
    i figured it out. its the remote mounted tfi ignition module. its located in the passenger side of the engine bay that is mounted to a metal thing with fins to keep it cool. i had a buddy of mine with the same car and he told me that it could be that so he let me borrow his good one to see if that fixed the problem and as soon as i plugged the good one in it started right up. thank you for all your help
     
    #15
  16. toyman

    toyman SN Certified Technician

    Joined:
    Jul 20, 2007
    Messages:
    1,855
    Likes Received:
    45
    Trophy Points:
    49
    Location:
    Vernon BC

    And from post #12 you missed this.


    That thing with the fins is called a "heat sink". Also, it's very important to have the mounting surface well coated with thermal paste (silicone dielectric compound). This ensures the heat generated in the module is transferred to the heat sink.
     
    #16
    Last edited: Jul 27, 2014
    jrichker likes this.

Share This Page