Engine 98 Gt Rough Idle And Squealing Sound From Engine

Discussion in 'SN95 4.6L Mustang Tech' started by Nick D, Dec 27, 2013.


  1. Nick D

    Nick D Member

    Joined:
    Jan 14, 2013
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    19
    my 1998 Mustang GT started squealing again after i replaced the belt 2 months ago. Right now, the car is running rough, shaking at idle, and squealing noise is coming from the engine bay. i had also noticed that i am able to wiggle the idle pulley with my hand. i did some research and that might need to be replaced. also, in the video of my car running (link below) i see the tensioner is jiggling at idle. i also did some research and read that it could also be caused by the bearing in the AC compressor pulley. this car is my daily driver and needs to be fixed as soon as possible.


    View: http://www.youtube.com/watch?v=zTjp-mlFars&feature=youtu.be
  2. trombonedemon

    trombonedemon Well-Known Member

    Joined:
    Jun 25, 2009
    Messages:
    2,559
    Likes Received:
    32
    Trophy Points:
    59
    Take the belt off and spin each accessory.
  3. Nick D

    Nick D Member

    Joined:
    Jan 14, 2013
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    19
    i had done that and it seems that the idle pulley has a grinding noise when it is spun. tomorrow i will go and get a replacement part
  4. Nick D

    Nick D Member

    Joined:
    Jan 14, 2013
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    19
    just to follow up, i had fixed the problem. The belt was completely fine, but the idler pulley and tension pulley were gritty. now my engine is running smooth and no unusual noises coming from it
  5. mustang.boyle

    mustang.boyle New Member

    Joined:
    Feb 26, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    2
    Put some water on belt during a start engine take abottle of water make a hole on cap and just put some water on belt this will help u to know of ur bearing is damaged the sound will not go and if fine the sound will go some time there is some oil on bearing so its make the belt to slip and produce sound like old doors

Share This Page