Check Engine light on full throttle?

Discussion in 'Other Auto Tech' started by Red_LX, Oct 23, 2007.


  1. Red_LX

    Red_LX I’m not much help unless you’re looking for porn! Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    10,691
    Showcase:
    2
    Albums:
    1
    Likes Received:
    35
    Trophy Points:
    89
    Location:
    Morgantown, WV...where couches meet their doom
    I just recently started driving my beater Tempo, and whenever you give it full throttle it very often throws a check engine light during or very soon after. It sticks around for a couple minutes and then goes away. Car runs fine though, is there any way to find out what's causing it? I doubt I could run codes since it goes away so fast.
    #1
  2. Jenns01TA

    Jenns01TA Active Member

    Joined:
    Mar 31, 2005
    Messages:
    1,112
    Likes Received:
    0
    Trophy Points:
    36
    My guess is a vacuum leak during WOT, EVAP issue or dirty sensor - MAF or a preliminary failure throw for an o2 sensor.
    #2
  3. Red_LX

    Red_LX I’m not much help unless you’re looking for porn! Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    10,691
    Showcase:
    2
    Albums:
    1
    Likes Received:
    35
    Trophy Points:
    89
    Location:
    Morgantown, WV...where couches meet their doom
    Hm.

    I hope it's not the O2 sensor, I'm tired of putting money in this car.

    I'll have to try cleaning the MAF and see if that helps.
    #3

Share This Page