Clunking noise in front suspension

Discussion in '2005 - 2009 Specific Tech' started by 08Bullittman, Mar 15, 2013.

  1. 08Bullittman

    08Bullittman
    Expand Collapse
    New Member

    Joined:
    Mar 14, 2013
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    1
    Location:
    Fort Hood, TX
    Hey guys, I have a noise in my front end whenever I go over a speedbump or a dip in the road. The struts still seem pretty firm and there is no play anywhere in the suspension. Is this common with the S197's?
     
  2. jpplaw

    jpplaw
    Expand Collapse
    Member

    Joined:
    Jan 14, 2009
    Messages:
    185
    Likes Received:
    3
    Trophy Points:
    18
    Check the swaybar links. They have to be ridiculously tight (89 ft lbs) or they cause clunking.
     
  3. jtthirdeye

    jtthirdeye
    Expand Collapse
    Member

    Joined:
    Apr 27, 2005
    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    14
    08Bullittman likes this.
  4. FordCustSrvc

    FordCustSrvc
    Expand Collapse
    Active Member

    Joined:
    Oct 25, 2010
    Messages:
    491
    Likes Received:
    33
    Trophy Points:
    29
    Location:
    Dearborn, MI
    Hello 08Bullittman,

    Welcome to the Forum! My name is Deysha with Ford Service, and I recommend you have your vehicle diagnosed at your Ford dealer. Your Service Manager is in the best position to look into this for you. He can check into any assistance, Recalls, or Customer Satisfaction Programs that may apply to your vehicle. Let me know the outcome.

    Thank you for the input, jtthrideye!

    Deysha
     
  5. 08Bullittman

    08Bullittman
    Expand Collapse
    New Member

    Joined:
    Mar 14, 2013
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    1
    Location:
    Fort Hood, TX
    Thanks guys for the input, I'll check out that TSB and also look at my swaybar links.