Engine Cylinder 3 misfire

Discussion in 'SN95 V6 Mustang Tech' started by brassman88, Nov 15, 2012.


  1. brassman88

    brassman88 New Member

    Joined:
    Nov 15, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Houston, Texas
    I have a 97 with a 3.8. I replace plugs wires and coilpack then starting getting a misfire on 3 (p0303) after reading some forums such as this i thought it might be te injector. Injector replace and still a misfire on 3. Any other possible solutions???? I did read somewhere it could be the crank sensor. Any help would be greately appriciated
     
    #1
  2. Noobz347

    Noobz347 Stangnet Facilities Maint Tech... Er... Janitor
    Admin Dude

    Joined:
    Jan 5, 1985
    Messages:
    20,564
    Showcase:
    59
    Albums:
    8
    Likes Received:
    2,664
    Trophy Points:
    174
    Location:
    Box behind Walmart
    Go down the list until you find the problem. My bet is on the coil pack or improperly seated plug wire.

    Faulty spark plug or wire
    Faulty coil (pack)
    Faulty oxygen sensor(s)
    Faulty fuel injector
    Burned exhaust valve
    Faulty catalytic converter(s)
    Running out of fuel
    Poor compression
    Defective computer
     
    #2
  3. greyfrankenstang

    Joined:
    Jan 17, 2013
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    7
    Location:
    Delaware
    I had a cylinder 1 misfire a few months back.
    Here's what i replaced to try and resolve the issue.
    Spark plugs
    Spark plug wires
    Coil pack (dont use a pepboys one, it broke about 2 weeks after i got it. Go OEM)
    Catalytic converter( both cats and pre cats)
    Cam shaft synchronization position sensor array
    Finally, i had to take it to a Ford repair place, and they informed me it was the injector.
    I did check the compression, but that tested ok.

    I see you replaced the injector first, so try my list if not noobz347. I'm curious what the culprit is on your car, so let me know when you find out.:)
     
    #3
  4. brassman88

    brassman88 New Member

    Joined:
    Nov 15, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Houston, Texas
    Thanks for the help i resolved my issue.....it ended up being a bad wire. I replaced the wires again and no more problems.
     
    #4

Share This Page