Door Sensor Problem????...

Discussion in 'SN95 4.6L Mustang Tech' started by Bob Hughes, Jun 30, 2013.

  1. Bob Hughes

    Bob Hughes Member

    Joined:
    Dec 27, 2011
    Messages:
    349
    Showcase:
    41
    Albums:
    1
    Likes Received:
    16
    Trophy Points:
    19
    Location:
    Southamptonl, NJ
    I have an 03 gt convertible, was doing oil change and putting on new brake rotors. Just noticed my interior lights are staying on and my alarm won't set (double beep) as though a door is open. What actually tells the doors they're shut? I saw a black push in piece on the back end of each door close to the latch area, but don't know if they actually control it, help please!!!!
     
    #1
  2. creektrack

    creektrack Member

    Joined:
    May 18, 2013
    Messages:
    149
    Likes Received:
    4
    Trophy Points:
    19
    Yes...those should be the switches, and one of them has probly failed...let the lights time out and then press in the driver and passenger switch separately and see which one is actually working properly...more than likely one or both needs replaced, cheap and easy fix...and sometimes a lil wd-40 goes a long way, being a convertible, moisture could have gotten to the switches and a lil wd-40 will dry it out...I have to do my navigator once every 6 months or so...

    Sent from my SPH-L720 using Tapatalk 2
     
    #2
  3. trinity_gt

    trinity_gt Advanced Member

    Joined:
    Jan 31, 2003
    Messages:
    3,050
    Likes Received:
    68
    Trophy Points:
    69
    Location:
    Canada
    On mine the driver's door fails to turn on the interior light. I thought it was the "door switch" and replaced it to no avail. I think I actually have a wiring fault between the door and the body.

    The switch is located inside the door, back by the latch mechanism. It's actually a bit of a PITA to remove. The interior door panel has to come off and you need to break your arm in three places to reach it.
     
    #3
  4. Bob Hughes

    Bob Hughes Member

    Joined:
    Dec 27, 2011
    Messages:
    349
    Showcase:
    41
    Albums:
    1
    Likes Received:
    16
    Trophy Points:
    19
    Location:
    Southamptonl, NJ
    Yea I messed with passenger one got it working. I guess maybe it got stuck
     
    #4

Share This Page