Dropping Engine-need Quick Help

Discussion in '1996 - 2004 SN95 Mustang -General/Talk-' started by SyberSaint, Feb 22, 2014.

  1. SyberSaint

    Founding Member

    Joined:
    Oct 25, 2000
    Messages:
    251
    Likes Received:
    5
    Trophy Points:
    19
    Location:
    San Antonio, Texas
    Dropping my engine and I have a hangup. The electrical connector on the pass side that has the 10mm bolt will not unplug. I loosened the the bolt and and the connector will not budge... Any ideas...The little plastic clip in the outboard side is not there.. Not sure what to do now.


    Syber
     
    #1
  2. SyberSaint

    Founding Member

    Joined:
    Oct 25, 2000
    Messages:
    251
    Likes Received:
    5
    Trophy Points:
    19
    Location:
    San Antonio, Texas
    its in my 2002
     
    #2
  3. Thatsweetstang

    Thatsweetstang Active Member

    Joined:
    Nov 4, 2013
    Messages:
    103
    Likes Received:
    7
    Trophy Points:
    29
    Location:
    Ca
    That harness is just stuck. 2 screw drivers and careful prying, I think there is 2 little clips in the inside like an older ford but I'm not sure.
     
    #3
  4. flstang65

    flstang65 Well-Known Member

    Joined:
    Dec 6, 2007
    Messages:
    1,976
    Likes Received:
    182
    Trophy Points:
    64
    Location:
    Mid Michigan
    What he said. Sometimes I like to put a little electrical grease on connectors that I know are generally stubborn.
     
    #4

Share This Page