egr help

Discussion in 'Fox 5.0 Mustang Tech' started by jdallen1798, Dec 4, 2003.


  1. jdallen1798

    jdallen1798 New Member

    Joined:
    Sep 16, 2003
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    kansas city kansas
    I just replaced the egr valve and the postioning sensor and the egr selonoid on the passenger side strut tower and the egr still does not work.i double and triple checked the vacum lines and they are correct.the egr solenoid has vacum coming in but none coming out to the egr valve.i have watched it at all different rpms and temps but the valve never opens.i have also checked the vac coming out of the solenoid at all temps and rpms and none is present.any ideas????????
    #1
  2. ss93cobra

    ss93cobra Founding Member

    Joined:
    Apr 10, 2002
    Messages:
    1,425
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Wilmington NC
    Have you checked voltage on the red power wire at the evr ? No power, no workie.
    #2
  3. jdallen1798

    jdallen1798 New Member

    Joined:
    Sep 16, 2003
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    kansas city kansas
    where does it get its power from??????????
    #3
  4. Psychdaddy

    Psychdaddy Founding Member

    Joined:
    Jun 14, 2002
    Messages:
    304
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Derby, KS
    The voltage will help you determine if the plunger is the correct length. If you have replaced both, you most likely will need to "lightly" sand the plunger to the correct length to get it to function properly.
    #4
  5. ss93cobra

    ss93cobra Founding Member

    Joined:
    Apr 10, 2002
    Messages:
    1,425
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Wilmington NC
    power for the evr comes from the computer.
    #5

Share This Page