Engine Engine Gets Too Hot.

Discussion in 'Fox 5.0 Mustang Tech' started by 95Vert383AOD, Sep 14, 2013.

  1. Motor is a 383 Stroker (From 351)

    Things ive checked

    1 No coolant leak, not a drop. Even used a pressure tester/ combustion leak tester.

    2 No air in system.... Car has thoroughly been ran on jack stands. I have bled this motor before and know how to get the air out.

    3 Combustion is good and even across the motor.

    4 Timing is at a safe 10-12 degrees right now

    5 Replaced Thermostat

    6 Replaced plugs (Looked Good)
    Here is what i did notice...

    1 Car can idle all day in park and stay at 180 degrees

    2 Soon as i start driving it the car goes to 210/215 (Autometer gauge)

    3 Infrared gun shows headers getting to 600+ degrees. You can really feel the heat being thrown off the motor

    4 Infrared shows around 200-210 degrees at the thermostat area when running too hot

    5 Radiator itself is in the 160's

    Other thoughts...

    I had MAC high flow cats re-installed to try and quiet down my car. There is no air tube connected. Is it possible that carbon has clogged my cats to the point where they create a restriction? I thought headers weren't supposed to get much above 300 degrees. This situation also creates enough heat to cause hard starting. I have a mild cam with mid .500's lift

    Thanks in advance,
  2. If you have cats and the thermactor tube is not hooked up, then your cats are most likely super heating, and/or clogged and that heat is backing up in your engine. However, you would notice a decrease in performance of the car. Is your smog pump hooked up? If you do not have your smog equipment installed, then remove the cats and install an H pipe.
  3. I have an x pipe.... Ill try taking temps before and after the cat to see if i notice anything drastic. I dont have a smog pump. Just cats with air tubes caped off. The car doesnt pull so well over 4/5000. I was just curious to see if high flow cats could do that with no air tube.
  4. That will do it right there ill bet the cats are clogged up.
  5. Its been driving me nuts.... In cooler weather like 60's there is no problem. If i cruise on the highway its not so bad either. But as soon as i start accelerating it warms up.
  6. if your cats hav an air tube, they were made to have air added to them for cooling them off. There are some cats without the tube needed
  7. You have , two options. One, swap in an off road H or X pipe and remove the cats Two, reinstall the smog pump,, TAD and TAB valves and vacuum hoses, Thermactor hose, and wiring. Check to see any of this is still present on the car first. Smog pump equipment is getting expensive. Your easiest route is the first option. If your cat pipe is still usable you can recoup the cost of the new mid pipe by selling the catted one.
  8. Yeah i removed ALL smog equipment. No going back now. I guess it would just be cheaper to order an off road X pipe than have an exhaust shop touch it.

    It creates insane heat under the hood. My fuel rails are reaching 200 degrees.
  9. Just a suggestion is the fan clutch working properly not slipping
  10. Its electric....its definitely pulling plenty of air. The headers are just throwing crazy amounts of heat. (not glowing yet though)
  11. I see you have an AOD...is the cooler lines going into the radiator?

    Sent from my XT907 using Tapatalk 2
  12. Nope the trans has its own stacked plate cooler.

    I'm just going to put an offroad mid pipe in. I have an H one....not sure how that will sound with this motor.
  13. My engine would warm up too, so I switched to a electric fan.. I have no smog system, have straight pipe no cats, engine stays cool now. :)