FUEL LEVEL LOW DTE ODO DATA ERR And CHECKING CHARGING SYSTEM

Discussion in '2005 - 2014 S-197 Mustang -General/Talk-' started by jawadagha, Mar 9, 2010.

  1. I was driving my car today the car stalls and dont wana start again.. ignition dont crank just a click from passenger side fuse box n some wierd noise from under the steering wheel.. its a 2006 v6 bought it in 06 no warranty.. nyone can help ???
     
  2. Your alternator might be shot and the car was running on battery until it was finally drained. Now you also might have a dead battery.
     
  3. can it be dead battery cells ??? everything in the car works just not the start.. it cant be dead battery..
     
  4. Sometimes the battery has enough juice to run the accessories but not enough cranking amps to start the car. Check your battery cables and if you're still convinced that it's not the battery then the only other thing I can think of is the neutral safety switch if you're an auto tranny or the clutch safety switch for manual. Maybe it's faulty.

    Edit: BTW, I assume you also checked the fuse in the SJB. Ford uses a slow blow fuse so unless you look really close you might not think its blown.
     
  5. yea i ll go get new batteries now... lets c..
     
  6. NOPe same thing no crank with new batteries..
    shows same error.. FUEL LEVEL LOW DTE ODO DATA ERR And CHECK CHARGING SYSTEM
     
  7. actually it is probably the fuel pumps hence the words "FUEL LEVEL LOW DTE ODO DATA ERR" I would suggest you have the dealer read the codes and repair it. This is not a job for amateur guessing games. IF they say that you need fuel pumps then you can expect a 500 dollar charge. :)
     
  8. redfire281 u were right..
    actually it was sjb fuse # 19 :p