fuel pump is not turning on

Discussion in 'Fox 5.0 Mustang Tech' started by jrockhall, Dec 20, 2003.

  1. jrockhall

    jrockhall New Member

    Joined:
    Aug 29, 2003
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    0
    I went to start my car and it just kept turning over and wouldn't fire up like it wasn't getting fuel or something so I had someone listen by the gas tank while I turned the key on and they said the fuel pump definitely isn't turning on. Now I could hear the fuel pump relay under my seat clicking on so does this mean that the fuel pump definitely went?? Is there anything else I should check before I drop my gas tank and replace the pump like I'm about to do in about an hour??? Btw, does anyone know of a good web site that shows exactly how to replace the pump. I have a chiltons but I just wanted another source. Thanks guys.
     
    #1
  2. 5.0Droptop

    5.0Droptop ...all those nights we shared, and you're a dude??

    Joined:
    May 16, 2002
    Messages:
    8,653
    Likes Received:
    1,089
    Trophy Points:
    173
    Location:
    Indiana
    try giving the tank a swift kick with the key on and see if it comes on, If it does the pump is done. If it dont the pump is prolly done anyhow.
     
    #2
  3. HISSIN50

    HISSIN50 "How long does it take to get help in here?
    SN Certified Technician

    Joined:
    Nov 30, 1999
    Messages:
    31,158
    Likes Received:
    14
    Trophy Points:
    79
    could also be your FP relay. jump the input and output and see if it works (or probe the output with key on when it should prime).
    good luck.
     
    #3
  4. ahuge1

    ahuge1 New Member

    Joined:
    Jun 3, 2003
    Messages:
    232
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    LUBBOCK,TX
    if the relay is working more than likly its the pump
     
    #4
  5. Mavrick

    Founding Member

    Joined:
    Aug 29, 2002
    Messages:
    2,266
    Likes Received:
    0
    Trophy Points:
    46
    Location:
    Collingwood, ON
    What about the inertia switch? That would be the first thing i'd check...
     
    #5
  6. ahuge1

    ahuge1 New Member

    Joined:
    Jun 3, 2003
    Messages:
    232
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    LUBBOCK,TX
    lmao, yeah thats no shyt.....
    been down that road, before i knew there was a such thing
     
    #6
  7. Ozz

    Ozz I think I have a problem here.
    Founding Member

    Joined:
    Jul 27, 2001
    Messages:
    3,726
    Likes Received:
    26
    Trophy Points:
    69
    Location:
    Canton, MI
    1. Check intertia switch.

    If that's not it, then:

    2. Replace the relay w/your AC one (or buy a new one, return if not needed). Takes 20 seconds to put it in, worth the time.

    If that's not it, then it's the pump.
     
    #7
  8. somersdp

    somersdp New Member

    Joined:
    Nov 16, 2003
    Messages:
    191
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    WPB,Florida
    Also check the in-line 18 gage fusable link and the eec relay. If either of those go out you get nada!! Does your check engine light come on when you turn the key to the on position, not cranking position?
     
    #8

Share This Page