Hci Install - Surging Idle Pointers

Discussion in 'Fox 5.0 Mustang Tech' started by Strype, Jun 17, 2013.


  1. Strype

    Strype Cuthbert catcher Founding Member

    Joined:
    May 11, 1999
    Messages:
    2,714
    Likes Received:
    371
    Trophy Points:
    104
    Location:
    Huntsvegas, AL
    Since my buddy just bought an 88 GT, I decided to get the cob webs off of the 93 and fix the idle problem. Some points for anyone else going through idle problems, especially after an HCI:

    1) You know that set of valve covers you just bought? Make sure you keep all air inside the motor because it's been through the MAF. Don't put a breather on the valve cover. Doing so causes major idle problems. Leave it hooked to the throttle body or risk blow back.

    2) Vacuum, vacuum, vacuum.

    3) Cone filters look cool. Too bad they jack your idle completely up. Even the stock fan causes too much turbulence for the MAF.

    4) Idle the car up a bit and then check TPS voltage. I installed a b303 and the car does NOT like to idle at less than 900-1000. Green wire is positive, put that black wire on your volt meter up against the nuts on top of the strut mount.

    5) If your fuel pressure gauge drops after you turn the car off... You have an injector that isn't seated. And ain't it a pain in the rear?

    6) If you don't have or are in between 02 sensors at the moment... There is a little plugin that you can buy that will make your motor think they're still there. Only do this on closed courses *cough*.

    7) jrichter.

    Now that she's idling maybe I can fix my gas into the oil problem.
    #1
  2. jrichker

    jrichker StangNet's favorite TOOL SN Certified Technician Founding Member

    Joined:
    Mar 10, 2000
    Messages:
    21,587
    Likes Received:
    355
    Trophy Points:
    134
    Location:
    Dublin GA
    The drop in fuel pressure can be a bad check valve in the fuel pump or a fuel pressure regulator with a small leak from pressure to return.

    Cheating the O2 sensors just cheats you of performance and economy. Instead of putting in some gizmo that lies to the computer, use the money to buy new O2 sensors. In the long run, your wallet with thank you. More fun per tank of fuel too.


    Setting the TPS at .98 or .99 volt is a Bozo Internet Myth. When the computer powers up and initializes the TPS sensor, whatever it reads is the zero starting point for it. In other words your .98 volt becomes 0 volts and the computer watches for increases in voltage from that point upward.

    Setting the TPS: you'll need a good Digital Voltmeter (DVM) to do the job. Set the TPS voltage at .5- 1.1 range. Because of the variables involved with the tolerances of both computer and DVM, I would shoot for somewhere between .6 and 1.0 volts. Unless you have a Fluke or other high grade DVM, the second digit past the decimal point on cheap DVM’s is probably fantasy. Since the computer zeros out the TPS voltage every time it powers up, playing with the settings isn't an effective aid to performance or drivability. The main purpose of checking the TPS is to make sure it isn't way out of range and causing problems.


    Wire colors & functions:
    Orange/white = 5 volt VREF from the computer
    Dark Green/lt green = TPS output to computer
    Black/white = Signal ground from computer

    TPS troubleshooting steps:
    1.) Use the Orange/white & Black white wires to verify the TPS has the correct 5 volts source from the computer.
    2.) Use the Dark Green/lt green & Black/white wires to set the TPS base voltage. Try this... All you need is less than 1.0 volt at idle and more than 4.25 at Wide Open Throttle (WOT). You'll need a voltmeter with a 1 or 3 volt low scale to do the job.

    The Orange/White wire is the VREF 5 volts from the computer. You use the Dark Green/Lt green wire (TPS signal) and the Black/White wire (TPS ground) to set the TPS. Use a pair of safety pins to probe the TPS connector from the rear of the connector. You may find it a little difficult to make a good connection, but keep trying. Put the safety pins in the Dark Green/Lt green wire and Black/White wire. Make sure the ignition switch is in the Run position but the engine isn't running. Set the voltmeter on the 2 volt range if it doesn’t auto range.

    Here’s a TPS tip I got from NoGo50

    When you installed the sensor make sure you place it on the peg right and then tighten it down properly. Loosen the back screw a tiny bit so the sensor can pivot and loosen the front screw enough so you can move it just a little in very small increments. I wouldn’t try to adjust it using marks.

    (copied from MustangMax, Glendale AZ)

    A.) Always adjust the TPS and Idle with the engine at operating temp. Dive it around for a bit if you can and get it nice and warm.

    B.) When you probe the leads of the TPS, do not use an engine ground, put the ground probe into the lead of the TPS. You should be connecting both meter probes to the TPS and not one to the TPS and the other to ground.

    C.) Always reset the computer whenever you adjust the TPS or clean/change any sensors. I just pull the battery lead for 10 minutes.

    D.) The key is to adjust the TPS voltage and reset the computer whenever the idle screw is changed.

    The TPS is a variable resistor, must like the volume control knob on a cheap radio. We have all heard them crackle and pop when the volume is adjusted. The TPS sensor has the same problem: wear on the resistor element makes places that create electrical noise. This electrical noise confuses the computer, because it expects to see a smooth increase or decrease as the throttle is opened or closed.

    TPS testing: most of the time a failed TPS will set code 23 or 63, but not always. Use either an analog meter or a DVM with an analog bar graph and connect the leads as instructed above. Turn the ignition switch to the Run position, but do not start the engine. Note the voltage with the throttle closed. Slowly open the throttle and watch the voltage increase smoothly, slowly close the throttle and watch the voltage decrease smoothly. If the voltage jumps around and isn’t smooth, the TPS has some worn places in the resistor element. When the throttle is closed, make sure that the voltage is the same as what it was when you started. If it varies more than 10%, the TPS is suspect of being worn in the idle range of its travel.

    TPS will not go below 1 volt
    Engine mounted sensor circuit: Check the resistance between the black/white wire on the TPS and battery ground. It should be less than 1.5 ohms. Higher resistance than 1.5 ohms indicates a problem with the 10 pin connector, computer or the splice inside the main harness where the wire from the 10 pin connectors joins the rest of the black/white wire.

    [​IMG]

    See the graphic for the location of the 10 pin connectors:
    Diagram courtesy of Tmoss & Stang&2birds

    [​IMG]

    See the graphic for the 10 pin connector circuit layout.
    [​IMG]

    Unplug the white 10 pin connector to do some resistance testing. It is good time to clean the connector pins and examine the connector for corrosion, broken wire or other damage. See http://oldfuelinjection.com/?p=85 for help in this department.

    If the resistance on the TPS Black/White wire and pin 1 of the white engine fuel injector harness 10 pin connector, is more than 1.0 ohm, you have bad connection or broken wiring. Repeat the test using the pin 1 of the white body side 10 pin connector and battery ground. You should have less that 1.5 ohm. More than that is a damaged signal ground inside the computer or bad connections or wiring.
    #2
  3. Strype

    Strype Cuthbert catcher Founding Member

    Joined:
    May 11, 1999
    Messages:
    2,714
    Likes Received:
    371
    Trophy Points:
    104
    Location:
    Huntsvegas, AL
    Oooooooh I'm taking vacation next week. Expect a thread or 3!
    #3
  4. 306N/A

    306N/A Member

    Joined:
    May 2, 2013
    Messages:
    95
    Likes Received:
    2
    Trophy Points:
    9
    Location:
    Ontario
    just bought a 65mm bbk tb, do i need to set the new tps or does it come set?
    #4
  5. 7991LXnSHO

    7991LXnSHO Active Member

    Joined:
    Sep 1, 2010
    Messages:
    1,116
    Showcase:
    5
    Albums:
    1
    Likes Received:
    89
    Trophy Points:
    49
    Location:
    Central USA
    TPS voltage WILL need adjusted after you get the idle opening adjusted no matter the brand.
    #5

Share This Page