Help Me Please!!! This Is My Daily Driver!

Discussion in 'SN95 4.6L Mustang Tech' started by samcrored, Feb 18, 2014.


  1. samcrored

    samcrored New Member

    Joined:
    Feb 18, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    2
    i have a 2000 gt, just bought it..brand new to fords in general. my problem is....
    the guy i bought it from had a clutch installed he said about 200 miles ago, ...note that the car is on sr lowering springs also....anyway

    when i start off in 1st to take off at a normal acceleration the car vibrates and shakes sort of like its going to stall, but also feels like wheel hop. i am not sure what is going on and i really need to get this taken care of!...also when i first start the car it goes smooth the first two or three times i take off. after that...horrible vibration/shudder. any help would be appreciated...thanks!
     
    #1
  2. trinity_gt

    trinity_gt Advanced Member

    Joined:
    Jan 31, 2003
    Messages:
    3,048
    Likes Received:
    68
    Trophy Points:
    69
    Location:
    Canada
    Sounds like clutch chatter. Bad clutch install (didn't resurface flywheel, got oil or grease on the clutch facing or flywheel etc) or he put a super-aggressive puck-style clutch and/or a disc with an unsprung hub.
     
    #2
  3. tonydalrymple

    tonydalrymple Active Member

    Joined:
    Nov 28, 2004
    Messages:
    158
    Showcase:
    13
    Albums:
    3
    Likes Received:
    28
    Trophy Points:
    39
    Location:
    Salt Lake City, Utah
    Mr. Trinity gt is telling it like it is IMHO....
     
    #3
  4. flstang65

    flstang65 Well-Known Member

    Joined:
    Dec 6, 2007
    Messages:
    1,971
    Likes Received:
    182
    Trophy Points:
    64
    Location:
    Mid Michigan
  5. SyberSaint

    Founding Member

    Joined:
    Oct 25, 2000
    Messages:
    251
    Likes Received:
    5
    Trophy Points:
    19
    Location:
    San Antonio, Texas
    +1 more.
     
    #5
  6. madspeed

    madspeed Colonel Mustard
    Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    8,604
    Showcase:
    9
    Albums:
    1
    Likes Received:
    1,258
    Trophy Points:
    174
    Location:
    a van down by the river
    agreed, poor install is my guess
     
    #6

Share This Page