Help! My odometer stopped turning ... what could it be?

Discussion in 'SN95 4.6L Mustang Tech' started by 96StangGT1020, Oct 7, 2005.


  1. 96StangGT1020

    96StangGT1020 New Member

    Joined:
    Aug 24, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    My odometer is stuck. What could it be?

    What's up guys.

    I have a '96 GT 4.6 li Automatic. My odometer, for some Godly reason, got stuck and is not turning anymore. Neither my trip nor the odometer are both not working. Has this happened to anyone? Any suggestions on what it could be? Expensive to fix?

    Thanks guys,

    96StangGT1020
    #1
  2. 96StangGT1020

    96StangGT1020 New Member

    Joined:
    Aug 24, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    What's up guys.

    I have a '96 GT 4.6 li Automatic. My odometer, for some Godly reason, got stuck and is not turning anymore. Neither my trip nor the odometer are both not working. Has this happened to anyone? Any suggestions on what it could be? Expensive to fix?

    Thanks guys,

    96StangGT1020
    #2
  3. mrvax

    mrvax Stay thirsty my friends Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    6,083
    Likes Received:
    2
    Trophy Points:
    79
    Location:
    SN Moderator: Orlando, Fl.
    1. Turn off the bold.
    2. Have you done a gear swap?
    3. Is your speedometer still working?
    #3
  4. 96StangGT1020

    96StangGT1020 New Member

    Joined:
    Aug 24, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0

    I haven't done anything to the car. It just all of a sudden stopped. The speedometer is still working. Everything but the odometer and the trip is working.
    #4
  5. jamez1502

    jamez1502 Banned

    Joined:
    Nov 6, 2003
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Lakeland Fl
    mine did the same thing. it was the gear inside the cluster that broke.. took me only 15 min to fix...
    #5
  6. jamez1502

    jamez1502 Banned

    Joined:
    Nov 6, 2003
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Lakeland Fl
    posted in the other one...
    #6
  7. timeless2

    timeless2 Vi Veri Veni Versum Vicus Vici Admin Dude

    Joined:
    Nov 30, 1999
    Messages:
    10,314
    Likes Received:
    96
    Trophy Points:
    89
    Location:
    the Shadow Gallery
    A blessing.
    #7
  8. [Twitch]

    [Twitch] Member

    Joined:
    Mar 31, 2005
    Messages:
    182
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Montreal
    Don't fix it!!! :D
    #8
  9. 1bad04GT

    1bad04GT New Member

    Joined:
    Jul 6, 2004
    Messages:
    176
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Lubbock, Texas
    does your speedo work? if not, your speedo cable may have snapped. I had the same prollem in my '90 GT. otherwise...:shrug:
    #9
  10. jcint

    jcint New Member

    Joined:
    Mar 31, 2005
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    wellington florida
    whats the mileage? maybe it's been tampered with. How long you've had it?
    #10
  11. jcint

    jcint New Member

    Joined:
    Mar 31, 2005
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    wellington florida
    Your traped in time! DEJAVU i think i seen this post before...........hmmmmmmmmmmm TIME MACHINE!
    #11
  12. sgarlic

    sgarlic Founding Member

    Joined:
    Apr 22, 2001
    Messages:
    3,100
    Likes Received:
    0
    Trophy Points:
    56
    Awww shucks.. a broken odometer, but the speedo still works. I wouldn't be in too much of a hurry to fix that little guy.
    #12
  13. Jinx

    Jinx I like cats. Cats like me. Cats & I fully agree Cat Lover

    Joined:
    Oct 2, 2003
    Messages:
    9,453
    Showcase:
    2
    Albums:
    1
    Likes Received:
    1,927
    Trophy Points:
    173
    Location:
    Cat Country
    #13

Share This Page