Help! Sputtering During Acceleration

Discussion in 'Fox 5.0 Mustang Tech' started by AUNNB3, Mar 12, 2014.


  1. AUNNB3

    AUNNB3 New Member

    Joined:
    Feb 16, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    2
    Location:
    Madison, Alabama
    I have a 1990 Mustang GT Convertible with 94K miles. Car is stock, I bought it about 4 weeks ago. First issue I noticed was it wasn't coming up to normal temperature. Now temperature is normal but the car bucks from a stop and durins acceleration. So I changed the thermostat (fun!). I assumed the carbon build up was pretty bad so I Did the seafoam through the vacuum lines thing. Better but still not quite right. Changed fuel filter, no change. Replaced spark plugs (that were gapped like .070) no change. The car starts and idles fine. If you rev the engine 2000-2500 it will hesitate. Sometimes when driving when I press the gas it will rev up to like 3000 rpm with no increase in power. Then other times there is no hesitation but it does not have typical 5.0 power. Help please!
    #1
  2. madspeed

    madspeed Colonel Mustard Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    8,421
    Showcase:
    9
    Albums:
    1
    Likes Received:
    1,224
    Trophy Points:
    174
    Location:
    a van down by the river
    Pull codes!
    #2
  3. jrichker

    jrichker StangNet's favorite TOOL SN Certified Technician Founding Member

    Joined:
    Mar 10, 2000
    Messages:
    21,700
    Likes Received:
    372
    Trophy Points:
    134
    Location:
    Dublin GA
    Dump the codes: Codes may be present even if the Check Engine Light (CEL) isn't on.

    Dumping the computer diagnostic codes on 86-95 Mustangs

    Revised 26-July-2011. Added need to make sure the clutch is pressed when dumping codes.

    Codes may be present even if the check engine light hasn’t come on, so be sure to check for them.

    Here's the way to dump the computer codes with only a jumper wire or paper clip and the check engine light, or test light or voltmeter. I’ve used it for years, and it works great. You watch the flashing test lamp or Check Engine Light and count the flashes.

    Post the codes you get and I will post 86-93 model 5.0 Mustang specific code definitions and fixes. I do not have a complete listing for 94-95 model 5.0 Mustangs at this time.

    Be sure to turn off the A/C, and put the transmission in neutral when dumping the codes. On a manual transmission car, be sure to press the clutch to the floor.
    Fail to do this and you will generate a code 67 and not be able to dump the Engine Running codes.

    [​IMG]

    [​IMG]

    If your car is an 86-88 stang, you'll have to use the test lamp or voltmeter method. There is no functional check engine light on the 86-88's except possibly the Cali Mass Air cars.

    [​IMG]

    The STI has a gray connector shell and a white/red wire. It comes from the same bundle of wires as the self test connector.

    89 through 95 cars have a working Check Engine light. Watch it instead of using a test lamp.

    [​IMG]

    The STI has a gray connector shell and a white/red wire. It comes from the same bundle of wires as the self test connector.


    WARNING!!! There is a single dark brown connector with a black/orange wire. It is the 12 volt power to the under the hood light. Do not jumper it to the computer test connector. If you do, you will damage the computer.

    What to expect:
    You should get a code 11 (two single flashes in succession). This says that the computer's internal workings are OK, and that the wiring to put the computer into diagnostic mode is good. No code 11 and you have some wiring problems. This is crucial: the same wire that provides the ground to dump the codes provides signal ground for the TPS, EGR, ACT and Map/Baro sensors. If it fails, you will have poor performance, economy and driveablity problems

    Some codes have different answers if the engine is running from the answers that it has when the engine isn't running. It helps a lot to know if you had the engine running when you ran the test.

    Dumping the Engine Running codes: The procedure is the same, you start the engine with the test jumper in place. Be sure the A/C is off, and clutch (if present) is pressed to the floor, and the transmission is in neutral. You'll get an 11, then a 4 and the engine will speed up to do the EGR test. After the engine speed decreases back to idle, it will dump the engine running codes.

    Trouble codes are either 2 digit or 3 digit, there are no cars that use both 2 digit codes and 3 digit codes.

    Your 86-88 5.0 won't have a working Check Engine Light, so you'll need a test light.
    See AutoZone Part Number: 25886 , $10
    [​IMG]



    Alternate methods:
    For those who are intimidated by all the wires & connections, see Actron® for what a typical hand scanner looks like. Normal retail price is about $30 or so at AutoZone or Wal-Mart.

    Or for a nicer scanner see www.midwayautosupply.com/Equus-Digital-Ford-Code-Reader/dp/B000EW0KHW Equus - Digital Ford Code Reader (3145It has a 3 digit LCD display so that you don’t have to count flashes or beeps.. Cost is $22-$36.
    #3
  4. AUNNB3

    AUNNB3 New Member

    Joined:
    Feb 16, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    2
    Location:
    Madison, Alabama
    Here is an update. Changed the distributer cap, spark plug wires, and the coil (this seemed to be the culprit coil wire at both ends had heavy corrosion). Car ran much better, but after dumping codes the check engine light came back on. I pulled codes and only got 32. Changed EGR valve, the thing was full of carbon! Cleared codes, CEL came back on again, pulled codes this time got 31. So I changed the sensor. Now the car won't idle worth a crap and when I pull codes I get 12. Feel like I just chasing the light.
    #4
  5. jrichker

    jrichker StangNet's favorite TOOL SN Certified Technician Founding Member

    Joined:
    Mar 10, 2000
    Messages:
    21,700
    Likes Received:
    372
    Trophy Points:
    134
    Location:
    Dublin GA
    You guys with idle/stall problems could save a lot of time chasing your tails if you would go through the Surging Idle Checklist. Over 50 different people contributed information to it. The first two posts have all the fixes, and steps through the how to find and fix your idle problems without spending a lot of time and money. I continue to update it as more people post fixes or ask questions. You can post questions to that sticky and have your name and idle problem recognized. The guys with original problems and fixes get their posts added to the main fix. :D

    It's free, I don't get anything for the use of it except knowing I helped a fellow Mustang enthusiast with his car. At last check, it had more than 134,000 hits, which indicates it does help fix idle problems quickly and inexpensively.

    The below information is from the Surging Idle Checklist.


    Code 12 -Idle Air Bypass motor not controlling idle properly (generally idle too low) - IAB dirty or not working. Clean the electrical contacts with non flammable brake parts cleaner at the same time.

    IAC doesn't work: look for +12 volts at the IAC red wire. Then check for continuity between the white/lt blue wire and pin 21 on the computer. The IAC connector contacts will sometimes corrode and make the IAC not work. The red wire on the IAC is always hot with the engine in run mode. The computer provides a ground for the current for the IAC. It switches the ground on and off, making a square wave with a varying duty cycle. A normal square wave would be on for 50% of the time and off for 50% of the time. When the idle speed is low, the duty cycle increases more than 50% to open the IAC more. When the engine speed is high, it decreases the duty cycle to less than 50% to close the IAC. An old-fashioned dwell meter can be used to check the change: I haven’t tried it personally, but it should work. In theory, it should read ½ scale of whatever range you set it on with a 50% duty cycle. An Oscilloscope is even better if you can find someone who has one and will help.

    [​IMG]

    Recommended procedure for cleaning the IAC/IAB:
    Conventional cleaning methods like throttle body cleaner aren’t very effective. The best method is a soak type cleaner used for carburetors. If you are into fixing motorcycles, jet skis, snowmobiles or anything else with a small carburetor, you probably have used the one gallon soak cleaners like Gunk or Berryman. One of the two should be available at your local auto parts store for $22-$29. Take the solenoid off the body and set it aside: the carb cleaner will damage some types of plastic parts. Soak the metal body in the carb cleaner overnight. There is a basket to set the parts in while they are soaking. When you finish soaking overnight, twist the stem of the IAB/IAC that sticks out while the blocker valve is seated. This removes any leftover deposits from the blocker valve seat. Rinse the part off with water and blow it dry with compressed air. The IAC/IAB should seal up nicely now. Once it has dried, try blowing through the bottom hole and it should block the air flow. Reassemble and reinstall to check it out.

    Gunk Dip type carb & parts soaker:
    [​IMG]

    Setting the base idle speed:
    First of all, the idle needs to be adjusted to where the speed is at or below 600 RPM with the IAC disconnected. If you have a wild cam, you may have to raise this figure 100-150 RPM or so. Then the electrical signal through the IAC can vary the airflow through it under computer control. Remember that the IAC can only add air to increase the base idle speed set by the mechanical adjustment. The 600 RPM base idle speed is what you have after the mechanical adjustment. The IAC increases that speed by supplying more air under computer control to raise the RPM’s to 650-725 RPM’s. This figure will increase if you have a wild cam, and may end up between 800-950 RPM

    Remember that changing the mechanical idle speed adjustment changes the TPS setting too.

    This isn't the method Ford uses, but it does work. Do not attempt to set the idle speed until you have fixed all the codes and are sure that there are no vacuum leaks.

    Disconnect the battery negative terminal and turn the headlights on. Leave the battery negative terminal disconnected for 5 minutes or so. Then turn the headlights off and reconnect the battery. This erases the computer settings that may affect idle performance.

    Warm the engine up to operating temperature, place the transmission in neutral, and set the parking brake. Turn off lights, A/C, all unnecessary electrical loads. Disconnect the IAC electrical connector. Remove the SPOUT plug. This will lock the ignition timing so that the computer won't change the spark advance, which changes the idle speed. Note the engine RPM: use the mechanical adjustment screw under the throttle body to raise or lower the RPM until you get the 600 RPM mark +/- 25 RPM. A wild cam may make it necessary to increase the 600 RPM figure to 700 RPM or possibly a little more to get a stable idle speed.
    Changing the mechanical adjustment changes the TPS, so you will need to set it.

    When you are satisfied with the results, turn off the engine, and re-install the SPOUT and reconnect the IAC. The engine should idle with the range of 650-750 RPM without the A/C on or extra electrical loads. A wild cam may make this figure somewhat higher.

    An engine that whose idle speed cannot be set at 600 RPM with the IAC disconnected has mechanical problems. Vacuum leaks are the #1 suspect in this case. A vacuum gauge will help pinpoint both vacuum leaks and improperly adjusted valves. A sticking valve or one adjusted too tight will cause low vacuum and a 5"-8" sweep every time the bad cylinder comes up on compression stroke. An extreme cam can make the 600 RPM set point difficult to set. Contact your cam supplier or manufacturer to get information on idle speed and quality
    Last edited: Mar 30, 2014
    #5

Share This Page