I Have A Tech. Question About My Mustang. (need A Mechanic's Input)

Discussion in '2005 - 2014 Specific V6 Tech' started by sw05Mustang, Jun 28, 2013.


  1. sw05Mustang

    sw05Mustang New Member

    Joined:
    Jun 28, 2013
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Hello! I have a tech. question regarding my 2005 Ford Mustang. (V6) Love my car by the way... anyway she's been having a few issues. A couple months ago I left for work like normal....she started just fine... and took off down the road ...but as I pushed on the gas she just didn't respond like usual. It was like she was dragging....the engine would rev up but the response just wasn't there. (keep in mind this is in a neighborhood and I don't usually go over 30 mpg....but that morning I couldn't get her to go over 20 mpg) It didn't last though... I let off the gas and reapplied the gas and she seemed to come out of it. (this happened a couple times - usually right after starting it in the morning) Another incident was when I stopped to drop something off. I left the car running dropped of the thing I needed to and got back in the car... put it in drive and pushed the gas and NOTHING happened!!! The engine didn't rev up it just did nothing...so I put it back in park waited a minute and then put it back into drive...still nothing! So I turned the car off....waited a minute or two and then turned it back on...started no problem...put it into drive and pushed the gas.... the car jerked and then took off just fine. It was about time for an oil change anyway....so I called our guy and got it in for him to take a look at and change the oil. He checked all of my fluids, changed the oil and looked her over. He said that he thought maybe I had gotten some bad gas and suggested using some fuel injector cleaner. (fluids were all good) I have always kept up with the care of my care....reg oil changes and everything. I do drive a lot and she has approx. 128,000 miles on her as of right now. So after I tried the fuel injector cleaner (did this a couple times) she ran like a dream...PERFECT! So I thought the problem was gone. But apparently not... last night on my way home from work....I stopped at a red light....waited for it to turn green... turned green and I pushed on the gas and the engine reved up but the car just didn't want to go. I think it made it up to 15mpg with the engine reved up before I let off the gas and re-applied the gas... it still didn't smooth out... it and then it happened... the wrench light on my dash lit up. (keep in mind I had been driving for nearly 35 minutes before this happened and I'm only 3-4 blocks from home!) Any other time I would have pulled over but with being so close to home I said a prayer and crossed my fingers and told her she couldn't die on me this close to home!!! (yes I talked to my car!) Luckily we made it home...going 35 mpg as I was afraid to let the engine rev up too high and she did seem to smooth out a little bit as I went. Pulled into the drive at home and turned her off. Sat there for a couple minutes and then decided to try to start her and see what happened..... turned over the key and she started with out a single issue. (she sounded great) and the wrench light was now off. ..... added fuel injector cleaner this morning and she drove like a dream to work... no issues at all....perfect.... so....WHAT IS WRONG WITH HER!? (I didn't get gas at the one place that I thought I'd gotten the bad gas from last time...been avoiding that place like the plague!) I asked a few friends and I've heard anything from Transmission to Cylinders being bad.... I just need some more opinions. Anyone with professional experience would be appreciated. I'm planning on taking her in again, cause she is nearly due for an oil change anyway...but thought it wouldn't hurt to get some opinions as to what might be wrong.

    Thanks!!!!!
    S
     
    #1
  2. madspeed

    madspeed Colonel Mustard Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    8,500
    Showcase:
    9
    Albums:
    1
    Likes Received:
    1,242
    Trophy Points:
    174
    Location:
    a van down by the river
    welcome aboard. you'd get better response by posting in a tech forum, but if its an auto and acting like that...

    1. check your tranny fluid level
    if no change, then
    2. change your tranny fluid and filter
    if no change, then
    3. time for a rebuild due to burning up the converter
     
    #2
  3. sw05Mustang

    sw05Mustang New Member

    Joined:
    Jun 28, 2013
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Fluid levels are good and my mechanic said the fluid looked clean... i'll have to check about the filter but I could have sworn he said that was good too.... so that just leaves rebuild...which is gonna cost. :cry:
     
    #3
  4. madspeed

    madspeed Colonel Mustard Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    8,500
    Showcase:
    9
    Albums:
    1
    Likes Received:
    1,242
    Trophy Points:
    174
    Location:
    a van down by the river
    sounds like the converter is shot
     
    #4
  5. sw05Mustang

    sw05Mustang New Member

    Joined:
    Jun 28, 2013
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    how much does a converter usually cost?
     
    #5
  6. madspeed

    madspeed Colonel Mustard Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    8,500
    Showcase:
    9
    Albums:
    1
    Likes Received:
    1,242
    Trophy Points:
    174
    Location:
    a van down by the river
    cost of parts isnt bad, it'll be the install that'll hurt your wallet
     
    #6
  7. sw05Mustang

    sw05Mustang New Member

    Joined:
    Jun 28, 2013
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    about how much do you think it'll cost me?
     
    #7
  8. sw05Mustang

    sw05Mustang New Member

    Joined:
    Jun 28, 2013
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    so there's no chance that it was just bad gas again?? Wishful thinking....
     
    #8
  9. madspeed

    madspeed Colonel Mustard Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    8,500
    Showcase:
    9
    Albums:
    1
    Likes Received:
    1,242
    Trophy Points:
    174
    Location:
    a van down by the river
    at a tranny shot i'd guess $600 or so. Local shop likely around $400
     
    #9
  10. sw05Mustang

    sw05Mustang New Member

    Joined:
    Jun 28, 2013
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    That's not too bad... I was afraid it was going to be more like $1000 or $2000..... Still not great news but thanks for your help. I guess i'll be taking it in to my mechanic.
     
    #10
  11. madspeed

    madspeed Colonel Mustard Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    8,500
    Showcase:
    9
    Albums:
    1
    Likes Received:
    1,242
    Trophy Points:
    174
    Location:
    a van down by the river
    what else did your mechanic say about the issue?
     
    #11
  12. sw05Mustang

    sw05Mustang New Member

    Joined:
    Jun 28, 2013
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Pretty much said he couldn't see anything wrong with it and that all the fluids and all looked good.
     
    #12
  13. sw05Mustang

    sw05Mustang New Member

    Joined:
    Jun 28, 2013
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Of course by the time he saw it, it was running just fine.
     
    #13
  14. echo7

    echo7 Member

    Joined:
    Mar 31, 2005
    Messages:
    551
    Likes Received:
    2
    Trophy Points:
    19
    Location:
    FL
    If it was the tranny, why would the engine not respond to the gas pedal being pushed down? Does the computer know something is up and refuses to give it more gas?
     
    #14
  15. jek57

    jek57 New Member

    Joined:
    Jun 29, 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    2
    When was the last time your fuel filter changed? It almost sounds like it might be clogged ,Start there if it has never been changed
     
    #15
  16. mustangclyde

    mustangclyde New Member

    Joined:
    Jul 16, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Just a thought, try the fuel pump, my car did the same thing, it creates air bubbles around the pump and sucks air, was common on 05's so I have found out, replaced it with one from and 09, no probs so far
     
    #16

Share This Page