Instrument Cluster Diagnostic Bulb Test- No Abs Light

Discussion in 'SN95 V6 Mustang Tech' started by Suek, Sep 25, 2013.


  1. Suek

    Suek Member

    Joined:
    Jul 11, 2013
    Messages:
    46
    Likes Received:
    7
    Trophy Points:
    19
    Hi,
    I did the Instrument cluster diagnostic test when it comes to the bulb test I don't the ABS light come on. I do see it when I start the car. I'm beginning to wonder if something IS wrong with my cluster for sure. I had the odometer fade when I pull the lights on and the fuel needle drop a little bet more than it should. I may take it out check for cold solder joints and calibrate it. Is anyone else not seeing the ABS either? Thanks .
     
    #1
  2. Mustang5L5

    Mustang5L5 Car used in adult film "Highway Gangbang-InDaButt" SN Certified Technician Founding Member

    Joined:
    Feb 19, 2001
    Messages:
    21,689
    Likes Received:
    319
    Trophy Points:
    124
    Location:
    Massachusetts
    Does your car have ABS. Not all mustangs were equipped.

    If your car did not come with ABS, then the bulb will not illuminate when you start the car.

    If it does have ABS...bulb is prob burned out
     
    #2
  3. Suek

    Suek Member

    Joined:
    Jul 11, 2013
    Messages:
    46
    Likes Received:
    7
    Trophy Points:
    19
    No it's there when I start the car, That's why I was like, "IS it supposed to be there? I think so it's a bulb test!" I'm trying another gauge today hopefully just too see it does. Then I did the test for fun (Seems like my mind thinks I'm going to find a magic thing in there Lol) and this time it says "none" (DTC) when it always gave that code for the oil pressure regulator. I think the thing must be only good for the tach or speedometer or maybe battery voltage. Too bad it's not like my old Dodge Daytona, It's onboard diagnostics were pretty good. Oh well, You can't have everything.
     
    #3
  4. Suek

    Suek Member

    Joined:
    Jul 11, 2013
    Messages:
    46
    Likes Received:
    7
    Trophy Points:
    19
    Tried a 2000 cluster and it showed the ABS. Ofcourse I knew the car wouldn't start because of the theft protection. I just wanted to see what would happen. The 2000's fuel gauge is slightly different and I think it gave slightly a better reading than my own. I think I'll try calibrating the other one and check the solder joints when I can. If I fix it I'll sell the other for 40 bucks on ebay. That's what I payed.
     
    #4

Share This Page