Instrument Panel Help?

Discussion in '1994 - 1995 Specific Tech' started by mattmathis, Mar 31, 2014.


  1. mattmathis

    mattmathis Member

    Joined:
    Apr 11, 2012
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    7
    My 94 GT speedo and tach are working fine, but the rest of the gauges are not working at all. Top possible causes or fixes for this?

    Odometer either, but I figure that's the gear and probably doesn't' have anything to do with the others, right?

    Thanks!
     
    #1
  2. 84Ttop

    84Ttop They make new pistons every day, so why worry? SN Certified Technician Mod Dude

    Joined:
    Jul 3, 2009
    Messages:
    3,266
    Likes Received:
    1,369
    Trophy Points:
    144
    Location:
    South Jersey
    I would start looking for a blown fuse. The odometer is digital? Are the instrument cluster lights working? Do you have a good engine ground? Just thinking out loud here...
     
    #2
  3. mattmathis

    mattmathis Member

    Joined:
    Apr 11, 2012
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    7
    Thanks! I really appreciate you trying to help me! No none of it is digital. Yes all the lights are working. Indicator and the guage lights. Do you mean the ground at the batter? If so then yes.
     
    #3
  4. dnbonds

    dnbonds Active Member

    Joined:
    Dec 17, 2013
    Messages:
    360
    Likes Received:
    69
    Trophy Points:
    39
    Location:
    Martinsburg, WV
    I'm not sure if this would help but maybe checking the sensors would fix it. I know my oil pressure on my cluster keeps flying around the place so I'm ordering a new oil pressure sending unit here soon.
     
    #4
  5. 84Ttop

    84Ttop They make new pistons every day, so why worry? SN Certified Technician Mod Dude

    Joined:
    Jul 3, 2009
    Messages:
    3,266
    Likes Received:
    1,369
    Trophy Points:
    144
    Location:
    South Jersey
    I would check the ground from the engine to the chassis. Usually located on the back of the drivers cylinder head.
     
    #5
  6. mattmathis

    mattmathis Member

    Joined:
    Apr 11, 2012
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    7
    ok, I'll check both of those things! Thank guys!
     
    #6
  7. revhead347

    revhead347 I have face herpes.

    Joined:
    Jun 14, 2004
    Messages:
    6,615
    Likes Received:
    286
    Trophy Points:
    124
    Location:
    Acworth, GA
    Check the fuses. If it were just the odometer I would say the plastic odometer gear was the culprit, but not when other gauges aren't working either. Read through the fuse section on you owner's manual if for nothing else to determine which circuit isn't working right. If it's not a fuse, you are going to be under their checking wires with a multimeter. PITA. Different gauges are not on the same fuse. The Speedometer is on the dome light fuse for some reason, the tach on another, and the others on another again.

    Kurt
     
    #7

Share This Page