Just installed Tweecer

Discussion in '1994 - 1995 Specific Tech' started by Guero, Sep 27, 2006.

  1. oops i didn't clean it. i was installing it like at 2 in the morning with little light. Damn figures, being lazy only makes you work double. clean it with what by the way
  2. I've heard some ppl use scotchbrite and rubbing alcohol...again, mine was already on the car when I got my car so I didn't have to clean my port....again, maybe someone will chime in.

    btw mOlO, good advice. It's always the simple things like that
  3. Hehehe yes its always like that!! just quoting the tipical Murphys Law :

    "If anything simply cannot go wrong, it will anyway."

    Or i would like to quote this for boost!

    " Murphy's Law of Thermodynamics
    Things get worse under pressure."

    lol!:rlaugh: :rlaugh: i am glad you solved this quickly , and for your question Guero , yes use a scotch brite , and some alcohol , but rub it slowly and just remove the stuff that is there , BE CAREFUL WITH THE CONTACTS dont thin them otherwise you will be looking for more trouble , just be careful!
  4. Cleaning the J3 port is the BIGGEST PITA with the install. I had to go over it a few times.

    I used a pencil eraser,rubbing alch., and even a very small dab of paint reducer (dont know if I would rec. this as it could cause an issue with the motherboard if too much is used).
  5. I used rubbing alcohol then a pencil eraser. Also make sure you find a way to secure your twEECer to the EEC - I put a spacer between it and the EEC where there was a gap and then used electrical tape to secure it.
  6. ok i will do all tomorow. I just got home from Bone thugs concert and aint to staright
  7. bone thugs....haven't heard them in a while
  8. isnt one of them in jail for accidently shooting one of the others while on probation???
  9. Flesh is in jail but i have no idea why.