Losing Power

Discussion in 'SVT Tech Forum' started by chuckystang, Aug 9, 2004.


  1. chuckystang

    chuckystang New Member

    Joined:
    Jul 12, 2004
    Messages:
    217
    Likes Received:
    0
    Trophy Points:
    0
    Anyone have any idea why every now and then I notice that from like 4k to 6k I have a loss in power to the real wheels. I notice it mostly in first gear, for instance when I accelerate, the car climbs as normal to about 4 or 5k but then instead of climbing progressively faster to the redline it seems to be held back and the power just isint getting to the wheels. My engine seems to be fine and no weird noises or smoke or anything obvious. Could this be something in my rearend?? clutch?? or something in the drivetrain? thats what Im thinking :(
  2. 97rmcobra

    97rmcobra Founding Member

    Joined:
    Apr 21, 2002
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Milford,MA
    Clutch could be slipping. How many miles are on the car?
  3. chuckystang

    chuckystang New Member

    Joined:
    Jul 12, 2004
    Messages:
    217
    Likes Received:
    0
    Trophy Points:
    0
    77k, but the CF dual friction has like 4k with new cable. but i was not aware that a slipping clutch could occur even after ive engaged 1st, because it is only in that gear. it is pretty noisy, probably throwout bearing, i just had a performance shop look at it and they said its fine but i should have used a stock cobra clutch aha, oh well, but they adjusted my cable and havent felt that loss in power to the rear yet, so ill keep ya updated :spot:
  4. Booya

    Booya New Member

    Joined:
    Jul 11, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    San Diego County
    Maybe your traction control?
  5. GTJim

    GTJim Founding Member

    Joined:
    Aug 17, 1999
    Messages:
    867
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Rio Rancho, NM
    Could be dirty air or fuel filters...
  6. chuckystang

    chuckystang New Member

    Joined:
    Jul 12, 2004
    Messages:
    217
    Likes Received:
    0
    Trophy Points:
    0
    thanks guys, and was that a mach 1 chin spoiler I see there, nice :nice: howd that go on there...
  7. Booya

    Booya New Member

    Joined:
    Jul 11, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    San Diego County
  8. chuckystang

    chuckystang New Member

    Joined:
    Jul 12, 2004
    Messages:
    217
    Likes Received:
    0
    Trophy Points:
    0
    sweet... how does it actually bolt on??
  9. Booya

    Booya New Member

    Joined:
    Jul 11, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    San Diego County

Share This Page