My 1990 Notchback Build Thread

Discussion in '1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk-' started by oatburner99, Jul 2, 2011.


  1. oatburner99

    oatburner99 Member

    Joined:
    Feb 21, 2010
    Messages:
    233
    Likes Received:
    19
    Trophy Points:
    19
    Location:
    Temple, TX
    I like it. easy to wire up. Easy to install...it's clean. The instructions are a little "meh" I have it wired up for 12v key on, that way when you shut the car off it doesn't stay running and kill the battery. But yeah so far so good....I had more money tied up in my Taurus fan than this....and this works better. Everyone slammed it saying it was a ****ty fan....I don't see that....it does the job :)
  2. rangerboy101

    rangerboy101 Active Member

    Joined:
    Oct 11, 2011
    Messages:
    330
    Likes Received:
    22
    Trophy Points:
    28
    Location:
    Inwood, WV
    Cool glad to hear that. Might have to pick one up
  3. oatburner99

    oatburner99 Member

    Joined:
    Feb 21, 2010
    Messages:
    233
    Likes Received:
    19
    Trophy Points:
    19
    Location:
    Temple, TX
    Well just a little update. Haven't done much recently. Scored some nice Gt seats and put those in.

    Picked up some UPR Billet caster camber plates to put in. Just need time to do it

    Anyway ...ON to the pics:

    [​IMG]

    [​IMG]

    [​IMG]

    A little bit of love:
    [​IMG]
    stangboy likes this.
  4. oatburner99

    oatburner99 Member

    Joined:
    Feb 21, 2010
    Messages:
    233
    Likes Received:
    19
    Trophy Points:
    19
    Location:
    Temple, TX
    Cleaned the old girl up today, and took a couple pics:

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]
    A5literMan and Vaz88GT like this.
  5. oatburner99

    oatburner99 Member

    Joined:
    Feb 21, 2010
    Messages:
    233
    Likes Received:
    19
    Trophy Points:
    19
    Location:
    Temple, TX
    Haven't done an update in awhile. So here goes.

    I've had 24 lb injectors and a maf waiting in the wings to go on the coupe for awhile now. Debating on if the car actually needed them. Well that was put on hold.

    I had noticed last week while driving to work (daily driven) that the car was just not running right. I had over time noticed that the fuel pump had been getting louder and louder. Not only that, but the car started running rough, I noticed when it was hot out side 100+ degrees that the car would ping and detonate. Which isn't good. That means running lean :( We all know what that means. Now when I did the clutch replacement, I found that the clutch was the original motorcraft (from 1990 LOL) so there was no doubt in my mind that the fuel pump was going to OEM. Low and behold...TAHHH DAHHHH yup. Original fuel pump.

    So I figured I would upgrade the fuel pump to give me some growth potential. I went with a Walbaro 190 lph fuel pump. So I had my 2 favorite little helpers, helping their daddy fix THEIR favorite ride:

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    Original Fuel pump
    [​IMG]

    Plain old 95 lph 24 year old fuel pump :)
    [​IMG]

    Old VS NEW
    [​IMG]

    All set to go back in:
    [​IMG]

Share This Page