Need Help

Discussion in '1996 - 2004 SN95 Mustang -General/Talk-' started by joeltx_2000, May 19, 2014.


  1. joeltx_2000

    joeltx_2000 New Member

    Joined:
    Jan 30, 2010
    Messages:
    5
    Showcase:
    3
    Albums:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Huffman,TX
    i got the reverse glow gauges from amerincam muscle tried to hook them up over the weekend . i followed the intructions but they do not light up , anyone have any ideas ? please help
     
    #1
  2. COramprat

    COramprat Drone Driver Mod Dude

    Joined:
    Mar 3, 2003
    Messages:
    6,221
    Showcase:
    21
    Albums:
    2
    Likes Received:
    147
    Trophy Points:
    113
    Location:
    Sea of Tranquility
    The only thing you can do is remove it and try again. You might find where you messed up a step.
     
    #2
  3. Three50won

    Three50won Member

    Joined:
    Jul 11, 2010
    Messages:
    850
    Likes Received:
    20
    Trophy Points:
    19
    Did you ground it properly? Did you run an inline fuse? Like what was already said, you might just need to go over everything again to find your mistake.
     
    #3
  4. Superhereaux

    Superhereaux chicks make me feel inadequate Founding Member

    Joined:
    Jul 30, 2002
    Messages:
    2,265
    Likes Received:
    7
    Trophy Points:
    59
    Location:
    South Texas
    May sound dumb but check the dimmer switch position.

    If that ain't it, like COramprat said, just re-install it
     
    #4

Share This Page