No Power To Fuse #5??

Discussion in 'Fox 5.0 Mustang Tech' started by ImportSlayer347, Feb 22, 2014.


  1. ImportSlayer347

    ImportSlayer347 Member

    Joined:
    Oct 13, 2008
    Messages:
    173
    Likes Received:
    1
    Trophy Points:
    19
    Location:
    Sarasota, FL
    All of the sudden today my turn signals quit working. I also noticed that my reverse lights and rear window defroster were not working. Definitely a problem at the fuse except the fuse was good. After putting a meter on the fuse socket there is no power. Any thoughts from the electrical gurus?
    #1
  2. ImportSlayer347

    ImportSlayer347 Member

    Joined:
    Oct 13, 2008
    Messages:
    173
    Likes Received:
    1
    Trophy Points:
    19
    Location:
    Sarasota, FL
    That didn't take long. Damn ignition switch (or the lock cylinder). I wiggled the key and everything started working again.
    #2
  3. Grabbin' Asphalt

    Grabbin' Asphalt Mustang Master

    Joined:
    Jun 11, 2013
    Messages:
    1,940
    Showcase:
    25
    Albums:
    1
    Likes Received:
    277
    Trophy Points:
    94
    Location:
    Atlanta, Ga
    Nothing like a little jiggle to liven thing up :rlaugh:
    #3
  4. madspeed

    madspeed Colonel Mustard Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    8,421
    Showcase:
    9
    Albums:
    1
    Likes Received:
    1,224
    Trophy Points:
    174
    Location:
    a van down by the river
    did you wiggle it, just a little bit?
    #4

Share This Page