Not Sure Whats Wrong...please Help Lol

Discussion in '1994 - 1995 Specific Tech' started by 1994gtmustang5.0, May 3, 2013.


  1. 1994gtmustang5.0

    1994gtmustang5.0 New Member

    Joined:
    Nov 26, 2012
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    I have a 94 gt 5.0. ) last week I was on the highway and it just stopped accelerating. So I pulled over and it died. Got it towed to a shop cause we werent sure what it was (had fuel and spark). They said it was the maf sensor...so whatever they fixed it and ran good....but yesterday it did it again, but this time I got it started and got it home fine....any ideas whats causing it? Seems like its mainly doing it at higher speeds....but maybe its coincidence. No clue. Just dont know where to start. Any suggestions?
    #1
  2. Bullitt95

    Bullitt95 Active Member

    Joined:
    Jun 13, 2007
    Messages:
    1,295
    Albums:
    1
    Likes Received:
    24
    Trophy Points:
    39
    Location:
    Al Ain, United Arab Emirates
    Have your engine computer scanned for fault codes (or buy your own code reader). A sensor problem will surely trigger a code and this will pinpoint the problem.
    #2
  3. 1994gtmustang5.0

    1994gtmustang5.0 New Member

    Joined:
    Nov 26, 2012
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    They ran a test on it and I guess a code came up pinpointing to the maf. But, im actually at the mechanics right now getting my fuel filter changed....and when he was changing it something deteoriorated....not sure what it was. So thats gotta be it? Lmao hell if I know anymore lol
    #3
  4. 1994gtmustang5.0

    1994gtmustang5.0 New Member

    Joined:
    Nov 26, 2012
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    But from what I know if the proper amount of fuel isnt going thru itll stall, especially at higher speeds. So im trying one thing at a time lol
    #4
  5. Chythar

    Chythar Well-Known Member

    Joined:
    Aug 26, 2004
    Messages:
    2,058
    Likes Received:
    8
    Trophy Points:
    58
    Location:
    West Los Angeles, CA
    Hmmm. So, you were driving and the RPM's just dropped? Like the engine was slowing down, even though you had your foot on the gas? When the engine died, it wouldn't restart until some time later? Just cranked and wouldn't start?
    #5
  6. 1994gtmustang5.0

    1994gtmustang5.0 New Member

    Joined:
    Nov 26, 2012
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
  7. Chythar

    Chythar Well-Known Member

    Joined:
    Aug 26, 2004
    Messages:
    2,058
    Likes Received:
    8
    Trophy Points:
    58
    Location:
    West Los Angeles, CA
    That happened to me when my CCRM module was failing on me, My mechanic had my car for a week driving it around until the problem came up. At that point, there was no electrical power to the engine past the CCRM. Apparently, the engine relay in the CCRM was on its way out.

    I don't know how to test if this is the problem you're having, since my mechanic did all the work. Perhaps someone else can chime in and give some advice?
    #7

Share This Page