Poor Idle And Stalling

Discussion in '2.3L (N/A & Turbo) Tech' started by TrevWB93, Jul 28, 2014.

  1. Hey! I have a 1993 Mustang 2.3 5-speed that's all stock. I love this car but recently I've had some issues with the idle. For awhile, I'd start the car and the RPMs would fall to about 500-600 then raise up to about 1500, and repeat for a little. It would usually go away after it started to warm up. I've replaced the Idle Air Control Valve, a new Motorcraft Throttle Position Sensor, and a PCV valve. It helped for awhile, but now the issue is back and it'll stall out. Won't rev up like before, but the RPMs will fall and stumble, I'll rev it, it'll do it again and eventually stop. Twice in a day I slowed down for traffic and as soon as I put the clutch in, the RPMs dropped quick then it stalled out. It would crank for a couple seconds then fire up. Did it again as I came into work, and I just clutch started it since I was rolling. I and a few techs I work with can't tell what it is. Thought it was fixed and it's come back. I really new the help!!! If anyone has any input or has come into this issue, it would be much appreciated! Thank you!
  2. No codes have come up. Check engine light has stayed off. We did a scan awhile ago and it was related to the TPS. I had an aftermarket one and swapped it for a motorcraft.
  3. Does the CEL come on and then go off when you start you the car? I've heard of people swearing up and down that they had no CEL when tryign to find a problem and it turns out they had tons of codes and the bulb was bad or missing.

    Anyway, have you run a KOER (key on engine running) self-test?

    Is the TPS set to 0.6V closed and does it increase smoothly up to 4.5V at open throttle?
  4. Base. Idle. Reset.