Problem: Windshield Wipers With Mind Of Their Own!

Discussion in '2005 - 2009 Specific Tech' started by slam_154, Dec 18, 2013.


  1. slam_154

    slam_154 Member

    Joined:
    Nov 25, 2013
    Messages:
    10
    Likes Received:
    2
    Trophy Points:
    14
    Hey guys, got a problem I've been dealing with for some time now and wondering if anyone else has experienced the same or similar. A few years back, my wipers just started going off on their own at random and I could not control them at all. Had to let it go for a while because I didnt have the money to deal with it at the time. A couple weeks later, smoke started rolling out of the cowl vents and I ended up having to pour a Mt. Dew on the wiper motor that had caught fire, not cool lol. I took the car to the dealership and they pulled the half melted wiper motor and revealed that it had somehow got stuck between high and low speed and shorted out. They replaced the wiper motor for $400 and it worked fine for about 8 months then they started going off on their own again. Before I could pull over out of traffic, the wipers stopped but then started discharging the entire wiper fluid reservoir and would'nt stop until it was empty. Finally got pulled over in a parking lot and I pulled the fuses to the wipers and the wiper fluid. Now I've just been making sure I keep a fresh coat of Rain-X on often and have dealt with the rain for the time being. So my long stories question is, Would this be a wiring issue where I would have to completely replace the wiring? A computer issue? Or was it just my luck that I got two faulty wiper motors in a row? Any input would be appreciated. Thank you!
    #1
  2. Az Pete

    Az Pete Member

    Joined:
    Mar 31, 2005
    Messages:
    598
    Likes Received:
    2
    Trophy Points:
    19
    I would look into the switching for the wipers. The multi function switches can act real funny at times. Sounds like Ford failed to locate the issue, just replacing the damage.
    #2
  3. slam_154

    slam_154 Member

    Joined:
    Nov 25, 2013
    Messages:
    10
    Likes Received:
    2
    Trophy Points:
    14
    Yeah it ended up being the switch, at least for now. Replaced the Switch and the fuses and everything is working properly so far, so I will give it another 8 months or so to see if it fails again. haha. thanks!
    #3

Share This Page