Question about C&L plenum, after the fact...

Discussion in 'SN95 4.6L Mustang Tech' started by dragginuts, Dec 6, 2003.


  1. dragginuts

    dragginuts Founding Member

    Joined:
    Oct 28, 2002
    Messages:
    248
    Likes Received:
    0
    Trophy Points:
    0
    I just put on my C&L plenum and everything went fine on the install. So i was driving home and the throttle kept sticking at the top, like the cable was sticking. Anybody else have this problem or maybe know what it could be from. I still have the stock TB.
    #1
  2. sapperstang78

    sapperstang78 Founding Member

    Joined:
    Mar 25, 2002
    Messages:
    101
    Likes Received:
    0
    Trophy Points:
    0
    I dont have any problems with a sticking throttle. But I also have an aftermarket throttle body.
    #2
  3. mhanna77

    mhanna77 New Member

    Joined:
    Jul 25, 2003
    Messages:
    158
    Likes Received:
    0
    Trophy Points:
    0
    check for the actual throttle plate to be sticking because of some type of alignment problem with the tb to the plenum. I know it doesn't make sense because the new plenum should have a lager opening but it's a problem I have seen in the past. (not with C&L).
    #3
  4. stangortwo

    stangortwo New Member

    Joined:
    Nov 10, 2003
    Messages:
    180
    Likes Received:
    0
    Trophy Points:
    0
    Hey check the vacuum tube that sits under the cruise control cable could be hanging up on the square part of the cable?
    #4

Share This Page