Question about my idle, please help!

Discussion in '1994 - 1995 Specific Tech' started by cmills26, Jan 4, 2004.

  1. For the last couple weeks I have noticed a change in my idle. When I start it up, it seems fine, but a few minutes later it revs up to like 2500rpm's and drops to like 500 rpms in an instant and my check engine light comes on and then goes back to it's normal idle with no check engine light on within a few seconds. Does anyone know what the problem could be? I know something has to be wrong but I am not sure what. Can someone try to point me in the right direction? Thanks for all your help!
     
  2. did you make any changes to the car directly before this started happening?
     
  3. No, I have not made any changes since this has happened. Could it be that I have a vacuum leak?
     
  4. that is very possible. go over the vacuum lines on the upper carefully. the thing is, i would think if it was a vacuum problem, it would do that constantly.
     
  5. Since your CEL light came on, you have a code stored in the computer. Run the codes and see what you get. Scott
     
  6. I used my code scanner and it said that my o2 sensors were bad and something about fuel pump circuit to battery. I have no clue what the latter means? Does anyone else know what this could be?
     
  7. although your o2 sensors will cause an intermittent cel, it will not cause your idle to do what it is doing.
     
  8. So what other possibilities could it be? When it comes to the mechanical stuff, I am clueless!