Running Bad At Low Rpm's

Discussion in '1994 - 1995 Specific Tech' started by EGULL64, Jun 30, 2014.

  1. EGULL64

    EGULL64
    Expand Collapse
    New Member

    Joined:
    Nov 16, 2013
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    2
    95 gt runs bad at low speed. Once I get over 40 it runs fine. I noticed a noise (fluttering sound) by the egr valve (see link for pic)
    No error codes just ran them. Has new-Dizzy, plugs, wires, cap. rotor, TFI Daily driver so I know it's not the gas. Oh timing is set.
    http://s1174.photobucket.com/user/egull64/library/?sort=3&page=1
    So could it be the EGR causing this problem? If so how do I check it being there are no error codes? If not the EGR what is the sputtering sound or what should I check for the sputtering sound.

    Thanks for any help.
     
  2. toyman

    toyman
    Expand Collapse
    SN Certified Technician

    Joined:
    Jul 19, 2007
    Messages:
    1,935
    Likes Received:
    50
    Trophy Points:
    49
    Location:
    Vernon BC
    EGR is a possible cause. Have you cleaned the MAF sensor element? The MAF is a critical sensor. No codes shouldn't be possible. There is at least a 111 pass code. Where are you testing from and do you have a code reader? The battery to engine and engine to chassis grounds need to be totally corrosion free for the sensors to function properly.
     
  3. EGULL64

    EGULL64
    Expand Collapse
    New Member

    Joined:
    Nov 16, 2013
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    2
    Yes I cleaned the MAF about 6 months ago & yes there was code 111. I'll check the connections.Thanks
     
  4. toyman

    toyman
    Expand Collapse
    SN Certified Technician

    Joined:
    Jul 19, 2007
    Messages:
    1,935
    Likes Received:
    50
    Trophy Points:
    49
    Location:
    Vernon BC
    If you have a K&N recharge filter you probably should clean the MAF again. Oil mist will affect the sensor signal.
     
  5. EGULL64

    EGULL64
    Expand Collapse
    New Member

    Joined:
    Nov 16, 2013
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    2
    not a K&n but after market one but I haven't used oil on it