Brakes Scrapin' And Squealin'

Discussion in 'SN95 V6 Mustang Tech' started by Okralord, Jun 28, 2013.


  1. Okralord

    Okralord New Member

    Joined:
    Jun 28, 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hello everybody,
    Started my 2000 V6 today to take a 3hr trip. On ignition the car began squealing off and on which sounded just like a fan belt wearing out.

    The car has also been making muffled scraping sounds indiscriminately while the car is moving at lower speeds (-20mph).

    These two things in conjunction has me wondering if it's more than just break indicators and an old fan belt.

    What do y'all think?
  2. Mustang5L5

    Mustang5L5 Car used in adult film "Highway Gangbang-InDaButt" SN Certified Technician Founding Member

    Joined:
    Feb 19, 2001
    Messages:
    21,609
    Likes Received:
    304
    Trophy Points:
    124
    Well, the car doesn't have a fan belt due to having an electric fan, but it's possible the serpentine belt or a pulley is failing?

    Have you popped the hood and attemped to look for the source of the sound? Diagnosing issues by sound over the Internet is not really practical. You'll have to do some legwork here and identify the source yourself.


    Sent from my iPhone 4S using Tapatalk
    Okralord likes this.
  3. Okralord

    Okralord New Member

    Joined:
    Jun 28, 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Aight, thanks for the help :-D It turned out to be that the brakes were worn out and the front roters needed to be replaced because of that :-(
    Also, the squealing hadn't reoccurred but the serpentine belt was old and needed to be replaced anyway.

Share This Page