Shaker 500 issues!!

Discussion in '2005 - 2009 Specific Tech' started by mustangsquared, Jul 10, 2006.

  1. Wow, they're still spewing that line, are they? Yup, keep replacing until your warranty runs out.

    I can't believe Ford are still knowingly throwing these pieces of junk into new Mustangs - shows the respect they have for their customers. Hearing this about the 06's, I wouldn't be surprised if removed units weren't simply being "fixed" and reinstalled. :nonono:
     
  2. Not an Alpine dealer. (Im a college professor.) Simply a guy who got frustrated and found a REAL fix. There are other brands out there that will also allow connection of an ipod and will sound great. But my research showed me that Alpine had the best controls and the cheapest cable at $29.
    I thought part of the idea of the forums was to pass on what we have found that works??
    I'll quit pushing Alpine and those who have found the Shaker 500 to be less than satsifying can do their own research.
     
  3. I purchased my car in Feb 05. Had the first Shaker 500 replaced in summer 05 (I complained about it since Feb, but they gave me some BS about back it being ordered). The new one had the same problems and I was told I should wait for the "next" version. I had it replaced again this past March and had the same problems. In April I installed a Pioneer AVIC-D2, XM, and IPOD attachment and have no regrets.
     
  4. i wish i would've read this topic before i punched my radio and cracked the screen all to hell.
     
  5. I just picked up a shaker 500 for $40 and I think I might pull it and sell it since it skips on pretty much all mp3s. Do the non shaker mp3 units do any better? If so I might get one. I like the stock look and having dimmer control.
     
  6. I guess I've been lucky. 5+ years and I've never had a problem.