Tb Whistle...

Discussion in 'Fox 5.0 Mustang Tech' started by MY 85 GT, Feb 1, 2014.


  1. MY 85 GT

    MY 85 GT Well-Known Member

    Joined:
    Mar 7, 2008
    Messages:
    1,463
    Likes Received:
    109
    Trophy Points:
    64
    Ok I was having a surging issue I took the IAC off cleaned it really good noticed it didn't have a gasket ordered one re-installed the IAC..I disconnected the Bat for about an Hour I also re-adjusted my TPS car seems to idle better but now I have this LOUD whistle from the intake...if I rest my foot on the Gas pedal it goes away...it still has a slight surge on Re-start even stalled one time...The car has a 70 mm BBK TB on it I have no EGR im usung a spacer with an EGR block off plate...Im wondering whats wrong NOW?.....
  2. 2000xp8

    2000xp8 Mustang Master

    Joined:
    Aug 9, 2003
    Messages:
    5,381
    Likes Received:
    218
    Trophy Points:
    104
    BBK throttle bodies are notorious for whistling.
    By fixing the gasket issue you probably sealed everything up making it whistle from the same place everyone has an issue with.

    I don't know what spot that is, but you are far from the first to complain of a BBK issue, enough so that when i read the title i figured "must have a BBK tb", sure enough...

    Do some google search for "mustang bbk whistle" there is some solutions out there. I've heard some people drill a little hole in the blade, but don't quote me on that.
  3. MY 85 GT

    MY 85 GT Well-Known Member

    Joined:
    Mar 7, 2008
    Messages:
    1,463
    Likes Received:
    109
    Trophy Points:
    64
    LOL...yeah I know I had heard that too...What other TB can I use then?...I will just get rid of the BBK....
  4. mikestang63

    mikestang63 Mustang Master

    Joined:
    Aug 28, 2012
    Messages:
    3,424
    Likes Received:
    891
    Trophy Points:
    144
  5. 2000xp8

    2000xp8 Mustang Master

    Joined:
    Aug 9, 2003
    Messages:
    5,381
    Likes Received:
    218
    Trophy Points:
    104
    Once you own an accufab throttle body it's hard to ever consider another brand. Just wish they weren't all polished.
  6. MY 85 GT

    MY 85 GT Well-Known Member

    Joined:
    Mar 7, 2008
    Messages:
    1,463
    Likes Received:
    109
    Trophy Points:
    64
    Thanks Guys that Accufab one looks nice they perform good too?...
  7. MY 85 GT

    MY 85 GT Well-Known Member

    Joined:
    Mar 7, 2008
    Messages:
    1,463
    Likes Received:
    109
    Trophy Points:
    64
  8. mikestang63

    mikestang63 Mustang Master

    Joined:
    Aug 28, 2012
    Messages:
    3,424
    Likes Received:
    891
    Trophy Points:
    144
  9. Noobz347

    Noobz347 Stangnet Facilities Maint Tech... Er... Janitor Admin Dude

    Joined:
    Jan 5, 1985
    Messages:
    19,470
    Likes Received:
    2,356
    Trophy Points:
    174
    This is pretty close to what you do. If you're lucky, this works the first time.

    What it requires is that you change the shape of the hole that's in the throttle body. On way of doing that, would be to drill it out. You can also use a small dremmel to make slight changes (to make it stop whistling).
  10. MY 85 GT

    MY 85 GT Well-Known Member

    Joined:
    Mar 7, 2008
    Messages:
    1,463
    Likes Received:
    109
    Trophy Points:
    64
    I read and a few people said to drill an 1/8 hole in the butterfly that might help I can try it will it hurt anything you think???
  11. madspeed

    madspeed Colonel Mustard Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    7,976
    Likes Received:
    1,111
    Trophy Points:
    174
    Easy dremel fix. 5 minutes and done
  12. smkshw

    smkshw Active Member

    Joined:
    Feb 12, 2010
    Messages:
    435
    Likes Received:
    56
    Trophy Points:
    39
    75mm and mine does the same thing....
  13. MY 85 GT

    MY 85 GT Well-Known Member

    Joined:
    Mar 7, 2008
    Messages:
    1,463
    Likes Received:
    109
    Trophy Points:
    64
    Ok I drilled the hole like they said I tried the idle re-set twice TPS is set perfect car idles pretty good...runs ok too...re-start still sucks!!!!!!!! surges and stalls...and then finally idles ok...after a minute or so but I still have to keep my foot on the gas to settle the surging down...Oh yeah the Damn whistle is still there...IM done this car gotta go!!!!
  14. Noobz347

    Noobz347 Stangnet Facilities Maint Tech... Er... Janitor Admin Dude

    Joined:
    Jan 5, 1985
    Messages:
    19,470
    Likes Received:
    2,356
    Trophy Points:
    174
    Is it too soon to start calling him New Jersey? :D
  15. madspeed

    madspeed Colonel Mustard Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    7,976
    Likes Received:
    1,111
    Trophy Points:
    174
  16. mikestang63

    mikestang63 Mustang Master

    Joined:
    Aug 28, 2012
    Messages:
    3,424
    Likes Received:
    891
    Trophy Points:
    144
    take off the IAC and smooth out the holes...
  17. MY 85 GT

    MY 85 GT Well-Known Member

    Joined:
    Mar 7, 2008
    Messages:
    1,463
    Likes Received:
    109
    Trophy Points:
    64
    Im hearing I should just replace the IAC im hearing its no good...Yes I know I can dremel the TB..i saw that thread...But can I just say ive had this CAR for over 5yrs it went from being blown to NA.back to blown now turbo all with the Same TB NEVER EVER NEVER did it make this noise...like I said the car was surging after a restart so I took the IAC off to clean in guess what there was no gasket...so I cleaned the IAC and installed it back with a gasket NOW its making this noise...and still surges not as bad but it does..Im thinking.maybe the IAC is no good...also I did get code 63...I checked the tps and I reset it to .98 key on car off...Also did the idle reset...all seemed ok..noise still there and car still surges after restart...that's why im confussed.....
  18. 88LX5.Oh

    88LX5.Oh Advanced Member

    Joined:
    Dec 31, 2011
    Messages:
    1,454
    Likes Received:
    210
    Trophy Points:
    74
    Take the IAC off and silicone that b*tch back up and if it still makes the noise, then you know it's nothing you did lol
    MY 85 GT likes this.
  19. madspeed

    madspeed Colonel Mustard Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    7,976
    Likes Received:
    1,111
    Trophy Points:
    174
    Silicone is for plumbers and boobs, put the correct gasket in there
    RangerJoe likes this.
  20. MY 85 GT

    MY 85 GT Well-Known Member

    Joined:
    Mar 7, 2008
    Messages:
    1,463
    Likes Received:
    109
    Trophy Points:
    64
    I guess no one reads my posts it used to Have RTV and no whistle...OK the car developed a surging problem after RE-start so I ran the codes then I decided to clean the IAC I took it off there was no GASKET...I cleaned the IAC re installed it with the gasket the car developed the whistle...and I did the re-set idle and adjusted the tps the car runs great on intial start up if I shut the car off and re-start it it will not idle well it will surge try to stall I have to keep my foot on the gas to keep it idling...once it settles and idles ok it runs fine again...if I shut it off the process starts all over agin it surges...So what should I try next????? honestly im giving up...I checked for Vac leaks spraying everything with Carb cleaner I didn't hear any..so im lost....

Share This Page