Transmission shake/shutter

Discussion in '1994 - 1995 Specific Tech' started by oosmytoo, Mar 4, 2013.


  1. oosmytoo

    Founding Member

    Joined:
    Jun 21, 2002
    Messages:
    530
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Portland - Oregon
    In need of expertise! So the other day I was doing a hard pull from first to second (basically a first through second gear burnout). After letting of, which at first I thought I had blown another head gasket. Got the car home checked the oil coolant etc. and everything looks fine. (Car free revs fine in park/neutral) but when in 1st or reverse it has a shake/shutter through about 3000rpms then cleans out and runs fine. I cannot power brake it now and burn out, which was no problem before. I'm determined it has something to do with the transmission possibly the converter or the transbrake. Also I put the car on jackstands and rolled through 1st,2nd,3rd and feels fine.

    Engine is a 331stroker with trick flow kit, and s trim blower at 12psi
    Transmission is a FB Performane 4stb-e with 3500 stall (basically a AODE with a manual valve body)
     
    #1
  2. 95Vert383AOD

    95Vert383AOD Active Member

    Joined:
    Jun 10, 2008
    Messages:
    1,300
    Likes Received:
    35
    Trophy Points:
    49
    Location:
    Providence, RI
    Sounds like you may have damaged the converter. Who makes the converter?
     
    #2
  3. oosmytoo

    Founding Member

    Joined:
    Jun 21, 2002
    Messages:
    530
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Portland - Oregon
    Converter was also done by FB Performance
     
    #3

Share This Page