Drivetrain Transmission Slips When I Put It In Drive 95 Mustang Gt

Discussion in '1994 - 1995 Specific Tech' started by Domenicteee, Jul 23, 2014.

  1. Domenicteee

    Domenicteee New Member

    Joined:
    Jul 23, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I just had the transmission oil and filter changed and when I put it in drive, the transmission will slip on occasion. Does anybody know what will remedy this. Dom
     
    #1
  2. Dacon

    Dacon Member

    Joined:
    Nov 7, 2005
    Messages:
    80
    Likes Received:
    15
    Trophy Points:
    18
    Location:
    Vancouver (no longer in hell!)
    Define your slip, is it in every gear, or just a certain gear?

    Is it slipping, or popping into neutral (no engine braking/no acceleration at all)?

    If it's popping into neutral, then catching a gear after the rpms come up/down, look into your Manual Lever Position Sensor (MLPS sensor, also called a neutral safety switch). About $30, easy fix.

    http://www.stangnet.com/mustang-forums/threads/94-gt-aode-issues.879144/ - pic/info on it.
     
    #2
  3. Domenicteee

    Domenicteee New Member

    Joined:
    Jul 23, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    It slips only when I put it in Drive. After its in drive, no slippage. It happens periodically but it seems that when the car has been running for a while it happens more. Any suggestions? thanks dom
     
    #3
  4. Chythar

    Chythar Well-Known Member

    Joined:
    Aug 26, 2004
    Messages:
    2,065
    Likes Received:
    10
    Trophy Points:
    58
    Location:
    West Los Angeles, CA
    Hah, pointed to the exact thing I was going to repost. I had the same problem with my old AODE when the plastic gear on the VSS stripped. Worth checking out both the MLPS and the VSS while you're under the car.
     
    #4

Share This Page