Updated TCP G-Bar triangulated 4-link...

Discussion in 'Classic Mustang Specific Tech' started by reenmachine, Nov 17, 2007.

  1. I did both an 8" and a 9". I knew the fixture wouldn't work with the 8" (well, it wouldn't bolt on -- it still worked fine for locating the brackets when clamped on) but I had the exact same experience as Blue Oval Man with the 9".
  2. I think I misunderstood the fitment issue. You're suggesting that adding a slot between the two pinion-offset bolt holes would enable the jig to be used with non-Mustang 9" housings with odd pinion offsets... that makes good sense. Is this correct?
  3. That is mostly correct, except for the non-Mustang part. I'm fairly certain the 9" housing I used is a Mustang unit and the jig wasn't quite right. I think Blue Oval Man's other housing was an original Mustang unit as well.

    I'd rephrase that as "...adding a slot between the two pinion-offset bolt holes would enable the jig to be used with 9" housings with odd pinion offsets...that makes good sense." :nice:

    Then there'd just be a big bold-face line about measuring twice and making sure the brackets are equidistant from the axle flanges.

    I'm also finding that some 8" people want to use their existing rear end assembly and they should be accommodated as well. This may mean another set of holes/slots or just a note to pop out a couple of studs as needed and clamp the fixture. Unfortunately I don't have one around any more to check the stud locations. We just popped studs out and clamped.
  4. I'll make sure that gets into the suggestions box before the next production run. I really appreciate the constructive product feedback.
  5. And thank you for listening. When these things go more smoothly we all win.
  6. Hey, found a stop with an internet connection tonight. Thanks for the response Psydwaze. The trouble with the welding jig also has something to do with the fact that both my original 68 Mustang 9" and my Versailles 9" have the pinion offset 1/4" to the side, not centered or 1" to the side as in the instructions. Hence, when the jig is positioned on the two pinion bolts, in the centered position, the upper arm brackets are off by a half inch. If I used the 1/2" position on the jig the brackets are off by 3/4". If the ultimate goal is to have these brackets spaced evenly from the ends of the axle flange, slotting the holes between the 0" and the 1/2" would allow the end user to snug the jig down with the pinion nuts and "wiggle" them into the correct location, then tighten down the nuts and you are good to weld. Otherwise, the axle brackets fit perfectly on the Mustang housing. On the Versailles housing, which is quite a bit larger, I would first make a cardboard duplicate of the axle brackets and cut them till they fit before grinding on the brackets, they have to have probably 3/4" removed to fit properly, no big deal.
  7. Psydwaze, What is the diameter of the steel poly bushed lower arms, and do they fill the width of the front spring mount location, or can they be offset to the inside to gain more tire clearance in a 65-66?
    Is 2" narrower the max that the rear housing can be narrowed with the G-bar in a 65-66?
    Any news about the possibility of pre-bent tailpipes over the housing?
  8. Just wanted to give some kudos to Pete (Reenmachine). I just purcahsed my G-bar from him and the service was exceptional. If anyone is serious about purchasing this system go through Pete. He charges the same price as TCP and you get his experience and knowledge. He gave me great advice and ended up saving my about $700 on options I thought I originally needed and really didn't. Thanks Pete! I will post some pictures once it gets installed.
  9. I second that. Just ordered mine today as well. Pete was great. Cant wait to get started on the install.

  10. My g=bar just arrived. One week after ordering...that was fast! Had to jump on it tonight just to see how it looks. Should be done this weekend.

    Mike J
  11. Got started on my install today as well. :)
  12. Any chance you can post some pics up Reen?
  13. Well mine is now in the car. The install seemed to go on without a problem. I had a quick question and sat on hold for TCP for 10 minutes before I gave up and called Pete over at Reenmachine. He answered the question in about 30 seconds. Thanks Reen!

    It looks like I will be running the exhaust under the rear. I will get it over to the exhaust shop when the body work is done and see what he can do. Maybe he will suprise me and be able to run it over the top.

    I am more than happy with the look and quality of this kit. It looks BAD A**! :rock: