Progress Thread Want To Blow 4 Years And $40k On A Foxbody? Step By Step Instructions Inside!

Discussion in '1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk-' started by RacEoHolic330, Nov 14, 2011.


  1. RacEoHolic330

    RacEoHolic330 I like to dress like a pretty girl SN Certified Technician

    Joined:
    Mar 5, 2003
    Messages:
    3,496
    Likes Received:
    695
    Trophy Points:
    153
    Location:
    Allentown, PA
    I wish I could make a panel like that. I got it custom made from gaugeplates.com. They make these on the same equipment that the billet aluminum dash plate is made on.

    I'm not going to have a need for the factory interior dimmer switch, so I'm going to contact them and see if they can make a plate to fill that area and put in a toggle switch instead.
  2. RacEoHolic330

    RacEoHolic330 I like to dress like a pretty girl SN Certified Technician

    Joined:
    Mar 5, 2003
    Messages:
    3,496
    Likes Received:
    695
    Trophy Points:
    153
    Location:
    Allentown, PA
    The dash gauges are fully functional and working now. The LED lights look bluish in the picture, but they are a pure white. The tach and speedo are a little dim, so I ordered some brighter bulbs to hopefully bring up the brightness a bit. The picture does make them seem brighter than they actually are. I'm happy with the way they look.

    [​IMG]

    The check engine light is functional as is the oil light. The PLX oil pressure sender has a built-in low pressure sensor. When the pressure hits 11.4 psi, it grounds the circuit out to illuminate the light. Pretty nifty.

    I also got the heater controls working. That was real easy to do using the factory wiring. The circuit is basically isolated and I just needed to splice into the 12V and ground to make it work.

    Most of the wiring is done. Here's what's left (as far as I can remember right now):
    -trunk popper
    -fuel door popper
    -line lock
    -interior lighting
    -fog lights (relay is wired up already)
    -fuel pressure regulator
    -boost controller
    -power mirrors
    -power doors and windows (can't do this until I get the doors back from the painter)
    -sound system (this will be the very last thing to wire)
    84Ttop, stangboy and 91chp notch like this.
  3. tamadrummer88

    tamadrummer88 Active Member

    Joined:
    Aug 19, 2005
    Messages:
    590
    Likes Received:
    74
    Trophy Points:
    39
    Location:
    Aloha State
    Cant wait to see this thing finished! Is it gonna have A/C as well?
  4. RacEoHolic330

    RacEoHolic330 I like to dress like a pretty girl SN Certified Technician

    Joined:
    Mar 5, 2003
    Messages:
    3,496
    Likes Received:
    695
    Trophy Points:
    153
    Location:
    Allentown, PA
    No a/c right now. The turbo piping made it difficult to keep. The weather in this area is mild enough that it wont bother me. If I want it bad enough down the road, I'll figure out a way to make it work.
    91chp notch likes this.
  5. rdharper02

    rdharper02 Member

    Joined:
    May 8, 2006
    Messages:
    436
    Likes Received:
    19
    Trophy Points:
    19
    Any problems with the drivers side turbo piping scorching the boot on your rack and pinion? Just noticed my new rack has gotten a little hot.
  6. RacEoHolic330

    RacEoHolic330 I like to dress like a pretty girl SN Certified Technician

    Joined:
    Mar 5, 2003
    Messages:
    3,496
    Likes Received:
    695
    Trophy Points:
    153
    Location:
    Allentown, PA
    I rebuilt my driver side header and the crossover pipe because it didn't work with my MM k-member. I shouldn't have any heat issues with the steering rack.
    [​IMG]

    Any other heat issues remain to be seen though.
  7. rdharper02

    rdharper02 Member

    Joined:
    May 8, 2006
    Messages:
    436
    Likes Received:
    19
    Trophy Points:
    19
    That's one way to do it! Your work looks great. I only wish I had the ability to do the same. For me, it will probably be some sort of heat wrap if I can think of a way to make it expand and follow the boot.
  8. RacEoHolic330

    RacEoHolic330 I like to dress like a pretty girl SN Certified Technician

    Joined:
    Mar 5, 2003
    Messages:
    3,496
    Likes Received:
    695
    Trophy Points:
    153
    Location:
    Allentown, PA
    Thanks man. Wrapping the crossover should definitely help. Right now, I just have my turbo and downpipe wrapped. I'm sure I'll have to wrap the rest of the pipes down the road. I'll have to see how well the ceramic costing performs.
  9. rdharper02

    rdharper02 Member

    Joined:
    May 8, 2006
    Messages:
    436
    Likes Received:
    19
    Trophy Points:
    19
    I'm going to see if I can't get a "bulk" buy on thermal wrap and show the kids how to wrap everything. I'll just tell them to be "creative" and drink a cool beverage as they go to town. On second thought, I better do it before something catches fire.
  10. madspeed

    madspeed Colonel Mustard Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    8,421
    Showcase:
    9
    Albums:
    1
    Likes Received:
    1,224
    Trophy Points:
    174
    Location:
    a van down by the river
    Bought all my wrap from siliconeintakes.com. several widths and lengths and great pricing
  11. RacEoHolic330

    RacEoHolic330 I like to dress like a pretty girl SN Certified Technician

    Joined:
    Mar 5, 2003
    Messages:
    3,496
    Likes Received:
    695
    Trophy Points:
    153
    Location:
    Allentown, PA
    The car is full of fluids now. Royal purple trans and gear fluid. Castol 10w-30 dyno oil for break in, which will be drained out after initial startup and first heat cycle. It was very foolish of me to forget to put the rear end fluid in before I installed it in the car. What a pain in the ass it was to pump the fluid out of the bottles with a hand pump. The POS pump kept leaking so I was left with a nice puddle of gear oil when I was done.

    I also got the fuel system all ready to go. I wanted to purge the lines with fuel to make sure there was no debris left over from assembling the fittings. I pulled the feeds off the rails and installed some push-loc fittings with some clear tubing on the ends dumped into a milk jug.
    [​IMG]

    [​IMG]

    This was also the first time I got to hear the Fuelab pump run. She makes some noise, but it does prime at full voltage and that's as loud as it will get. When the car is idling, it will run at a reduced voltage based on the regulator pressure. I don't think the pump will be very audible over the sound of the exhaust at idle. The quick half-second prime that the ECU does when the key is turned is not enough to prime an empty fuel system, so I jumped the fuel pump relay self-test port to ground to get the pump to run until I turned the key off. Didn't take long at all until fuel flowed through the clear hoses.

    Once I pumped about 1/4 gallon through the lines, I hooked the fuel lines to the rails and then pumped a little more on the return side of the rails to purge the lines before the regulator.
    [​IMG]

    After that, I hooked up the return to the regulator and removed my jumper. Turned the key and the system pressurized itself to 20psi. I adjusted the regulator and got it up to about 40psi. Had a small leak I missed when I pressure tested the lines. Other than that, everything seems good to go. I'm going to keep checking for leaks just to be sure. The pressure bleeds down to 30psi in about 25 seconds and then it takes a few minutes to get to 20, where it holds for quite a while. This seems normal to me. I know bleed down can be factored by the check valve at the pump (mine is in the filter) and the regulator itself.

    There isn't much left to do before I'm ready to fire the engine up. Should be ready in a few more weeks.
  12. Noobz347

    Noobz347 Stangnet Facilities Maint Tech... Er... Janitor Admin Dude

    Joined:
    Jan 5, 1985
    Messages:
    20,118
    Showcase:
    58
    Albums:
    5
    Likes Received:
    2,544
    Trophy Points:
    174
    Location:
    Box behind Walmart
    Quick Note:

    I haz to eat sum werdz... I recently got Momma a SUV with awd. It has a REALLY nice set of analog gauges for tach and speedo. Nestled in the middle of all of that, is a multi-function display. It's digital.

    I don't dislike it at all. I actually really like the seemingly, "heads up" display.

    So it's all about implementation I guess.

    Please resume your regularly scheduled program. :D
  13. RacEoHolic330

    RacEoHolic330 I like to dress like a pretty girl SN Certified Technician

    Joined:
    Mar 5, 2003
    Messages:
    3,496
    Likes Received:
    695
    Trophy Points:
    153
    Location:
    Allentown, PA
    Hah! It seems that just about all manufacturers are doing the digital/LCD display between the tach and speedo these days. From Audi to Ford, they all have it. I like it a lot. I had a gf with an A4 and I loved how it displayed the speed as a readout in the middle.
  14. Noobz347

    Noobz347 Stangnet Facilities Maint Tech... Er... Janitor Admin Dude

    Joined:
    Jan 5, 1985
    Messages:
    20,118
    Showcase:
    58
    Albums:
    5
    Likes Received:
    2,544
    Trophy Points:
    174
    Location:
    Box behind Walmart

    Pics of gf... in bikini... or it didn't happen. :p
    ry94stang50, stangboy and 88LX5.Oh like this.
  15. 1991vert

    1991vert Active Member

    Joined:
    Feb 28, 2004
    Messages:
    1,106
    Likes Received:
    7
    Trophy Points:
    39
    Location:
    Ludlow, MA
    i just read through this from the beginning...coming along nicely. threads like this motivate me to work on my car, then my wallet reminds me that i have no monies
  16. RacEoHolic330

    RacEoHolic330 I like to dress like a pretty girl SN Certified Technician

    Joined:
    Mar 5, 2003
    Messages:
    3,496
    Likes Received:
    695
    Trophy Points:
    153
    Location:
    Allentown, PA
    I haven't updated the thread in a bit, but I have been making progress on the car. Even though it doesn't look like it, the wiring is nearly done. I just have to finish up the dummy lights and the switches that are going in the ash tray.
    [​IMG]

    Once I finish those things and a couple of vacuum lines, I can get everything bundled up and install the dash.

    The engine is 100% ready to start besides from the silicone coupler for the throttle body. I somehow lost the one I bought and had to get another one.
    [​IMG]

    One issue I had was when I was checking the TPS voltage. I couldn't get my PMS to read IDLE and WOT to save my life. Pushing the pedal to the floor would only get me 75% throttle. I checked the throttle blade by hand and noticed it was only opening up 3/4 of the way. I suspected the throttle cable I bought from LRS could be the problem. It was bottoming out before the throttle blade could open all the way. I bought an OEM cable on ebay and compared the two. The LRS cable was about 1" longer than the OEM cable when both cables were fully compressed. I installed the OEM cable and the throttle opened all the way with no problems. TPS voltages checked out okay as well. The lesson here: don't but a throttle cable from LRS. Stay OEM.

    My painter also gave me a nice surprised last week...
    [​IMG]

    [​IMG]

    He still has to finish the other body panels. The plastics will be sanded and buffed when they are mounted on the car. It's easier that way. The paint did lay out very well though. I'm happy with them.

    Once I get a 40ish degree day here after I have the dash wiring done, I can see if this thing actually runs :burnout:
  17. GroverDill

    GroverDill GoldMember

    Joined:
    Aug 19, 1999
    Messages:
    4,808
    Likes Received:
    321
    Trophy Points:
    114
    Location:
    Rathdrum ID 83858
  18. RacEoHolic330

    RacEoHolic330 I like to dress like a pretty girl SN Certified Technician

    Joined:
    Mar 5, 2003
    Messages:
    3,496
    Likes Received:
    695
    Trophy Points:
    153
    Location:
    Allentown, PA
    I decided to mount up the side skirts while the paint was still fresh. These skirts tend to curl when not installed and I didn't want to chance the paint cracking when installing them. I riveted in the new mounts and bent the skirts into place. They fit like a friggen glove. Nothing beats OEM parts. No glue, no double sided tape. They aren't screwed in yet, just sitting on the mounts so they hold their shape.
    [​IMG]

    [​IMG]

    I also needed to make a set of brackets to mount the rear cobra brackets. Some strips of 16ga steel and some screws welded to the steel did the job. I shot them with some rattle can paint to keep them from rusting.
    [​IMG]

    [​IMG]

    I mounted the bumper, but don't have pictures yet. It fits perfectly. Much better than the Cervinis bumper I had originally bought.

    I'm in the final stretch of the wiring. Here's the ash tray switch with the weatherpack connectors and the USB adapter for the PMS.
    [​IMG]

    [​IMG]
    stangboy, 91chp notch and A5literMan like this.
  19. madspeed

    madspeed Colonel Mustard Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    8,421
    Showcase:
    9
    Albums:
    1
    Likes Received:
    1,224
    Trophy Points:
    174
    Location:
    a van down by the river
    Meh, just another black fox :cool:
  20. A5literMan

    A5literMan Mustang Master

    Joined:
    Jul 31, 2011
    Messages:
    1,252
    Likes Received:
    334
    Trophy Points:
    94
    Location:
    Illinois

Share This Page