weird CE light.....

Discussion in '1994 - 1995 Specific Tech' started by VIPERn94Five-0, Dec 13, 2003.


  1. VIPERn94Five-0

    VIPERn94Five-0 Founding Member

    Joined:
    Apr 29, 2002
    Messages:
    3,352
    Likes Received:
    0
    Trophy Points:
    56
    Location:
    Poughkeepsie, NY
    went out to lunch with the girlfriend today before she had to go to work and while i was driving home i was slowing down(very slightly) to make the right onto my road and my Check Engine light flipped on...stayed on for like 5 seconds(if even that long) and then went off....didnt come back on for the next couple mins it took to get home.....just wondering if the could mean anything specific???



    Anthony
    #1
  2. Joes95GT

    Joes95GT New Member

    Joined:
    Jan 23, 2003
    Messages:
    3,138
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Delaware
    I would say that a sensor in the throttle body is on it's way out, but you have a semi new TB so I wouldn't think it was that. Can you pull codes and see what you get? I would say either the TB or the o2's. No big deal. The car will still drive perfectly fine.

    Joe
    #2
  3. 94GTLaserRC

    94GTLaserRC Squint as you approach, lest you be blinded by my

    Joined:
    May 7, 2002
    Messages:
    11,187
    Likes Received:
    8
    Trophy Points:
    79
    Location:
    Ernan Says "here it comes... dushbag"
    You need to get a scanner, run the codes, and see what it says.

    If you have a rich or lean condition, it may pop on and off intermittently..

    RC
    #3
  4. 1o1PRooF

    1o1PRooF New Member

    Joined:
    Jun 22, 2001
    Messages:
    857
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    West TN.

    What he said.

    Don't waste time or money guessing, pull the codes and see whats going on.
    #4
  5. Green 94 5.0

    Green 94 5.0 Founding Member

    Joined:
    Mar 25, 2002
    Messages:
    2,596
    Likes Received:
    6
    Trophy Points:
    49
    Location:
    Ft. Lauderdale, FL
    99% sure it is your o2 sensors. get the code scanner to be sure though.
    #5
  6. QCStang

    QCStang Founding Member

    Joined:
    Mar 29, 2002
    Messages:
    899
    Likes Received:
    15
    Trophy Points:
    18
    Location:
    Aylmer, Quebec, Canada
    Mine did that when it was in 'limp' mode.

    Check your codes ASAP!
    #6

Share This Page