whats up guys

Discussion in 'The Welcome Wagon' started by Devcon, Jul 19, 2011.

  1. Devcon

    Devcon Member

    Joined:
    Jul 19, 2011
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Kansas
    hey
    Im from kansas and am new to the mustang world. my dad had a mach 1 and ever since then I wanted a mustang. I am now a very proud owner of roush with the shaker hood:D Ive been having some fun fixing some random problems. like a bent shifter plate (was over torqued) and now a leaking yoke. I also have some kind of weird problem with the gauges messing up. the gas gauge is wrong, the speedo is off by 5mph, and the rpms are off by about 500. How can i fix that? thanks
     
    #1
  2. N8Dogg98

    N8Dogg98 Banned

    Joined:
    Apr 5, 2005
    Messages:
    10,181
    Likes Received:
    512
    Trophy Points:
    154
    Location:
    MN
    welcome! lets see some pics :)
     
    #2
  3. AMChrisYoung

    AMChrisYoung Member

    Joined:
    Nov 30, 1999
    Messages:
    129
    Likes Received:
    3
    Trophy Points:
    16
    Location:
    Malvern, PA
    Welcome to the forum!

    Sounds like you have a great 'Stang!

    I would pull the entire gauge cluster and make sure everything is connected properly and there are no funny, disconnected wires. You may have gears in the car, but that would not explain your RPMS being off.

    I hope this helps, good luck!
     
    #3
  4. Devcon

    Devcon Member

    Joined:
    Jul 19, 2011
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Kansas
  5. Devcon

    Devcon Member

    Joined:
    Jul 19, 2011
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Kansas
    friends lift makes life sooo easy. Is there anyway to recalibrate it with out taking the gauges out?
     
    #5

Share This Page