Whoohoo! Finally got back to having decent internet access! Got a question too!

Discussion in '1974 - 1978 Mustang II Talk & Tech' started by 74stang2togo, Aug 24, 2006.


  1. 74stang2togo

    74stang2togo I have never done anything CT worthy. :( Founding Member

    Joined:
    Mar 7, 2002
    Messages:
    2,052
    Likes Received:
    230
    Trophy Points:
    84
    Location:
    Texas, HOWDY DAMMIT!
    #1
  2. Wart

    Wart I'm Mad as HELL and I'M not Gonna Take it ANYMORE! Founding Member

    Joined:
    Sep 1, 1998
    Messages:
    3,121
    Likes Received:
    0
    Trophy Points:
    56
    Location:
    NE Ohio
    They look right. If they're not too rusted you should be able to see a D5Z part number.
    #2
  3. Power Surge

    Power Surge Founding Member

    Joined:
    Jul 20, 2002
    Messages:
    1,519
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Palm Coast, FL
    They look right to me, and impressively, the drivers side still has the FACTORY extention pipe on it.
    #3
  4. 74stang2togo

    74stang2togo I have never done anything CT worthy. :( Founding Member

    Joined:
    Mar 7, 2002
    Messages:
    2,052
    Likes Received:
    230
    Trophy Points:
    84
    Location:
    Texas, HOWDY DAMMIT!
    Thanks, I was thinking they looked right, but I'd only ever seen them ON the car on Mustang IIs, and once in a Toyota 4x4 with a 289 (almost bought it, probably should've at $1200, ran and drove great with the 289 in it).

    So... Wart is now MadMark? (I seriously need to get back here more often!!!!!)
    #4

Share This Page