Wierdest Problem (Exploder)

Discussion in 'Other Auto Tech' started by Strype, Jan 16, 2008.

  1. Hey guys, someone I work with needs help and he doesn't know where to turn.

    He has a 2003 Explorer, v6. Driving down the road yesterday the "oil cap" warning light came on and then poof the power steering fails and the car loses all power EXCEPT for the brakes...

    Today he said the "tire pressure" light came on and then POOF! The same thing?


    Anyway it's his wife's car and that could cost her her life if it happens to her on teh interstate :(
  2. I'm going to move this to other auto.
  3. first off there is no low oil light. i just called the ford dealership to verify. he said if the low oil light comes on and the oil pressure drops the engine will cut off as a safety measure and the same goes for he low tire pressure. tell him/ her to check there oil and tire pressure.
  4. Thanks raggy!

    No poop? I think it was the "loose oil cap" light or sumthin.

    So the damned thing will cut off as a safety???? :eek:
  5. WTF? You mean TIRE pressure will kill your engine, now?!? :eek:

    Seriously. I don't think I'll ever buy a Ford car newer than '04, now. That's just insanity. :nonono:
  6. I call bull on that one. My 2003 limited had the system and the light has come on and the truck never shut off and 2 tires had low pressure one time, I waited until I got home filled them and then reset the system. my 2007 limited has the newer system and the light came on due to faulty sensor and the truck never shut either, we checked the tire pressures and they where okay drove it for a week just had to hit the reset button on the info center every time we restarted the truck to shut it off the minder intil ford fixed it. The system is very easy to deal with, I have winter wheels on it now ( don't want to eat up the chrome ones) and bought the ford sensor reset tool on ebay. takes 2 minutes to reprogram the new wheel sensors for the winter wheels and then I have to again in the spring that is the only suck part.
  7. Check Battery connections

    Check the battery connections, If loose you could lose all power. That happened in my 2000 Focus. The negitive terminal was loose on the battery, my car would lose power, then regain power after a restart. I tightnend the connector and no problem since. I hope this helps.