WTB: carb for 1965 6cyl. 200ci

Discussion in 'Engine and Power Adder' started by raidmagic, Sep 26, 2007.

Thread Status:
Not open for further replies.
  1. Anyone have one? A buddy needs it and I am trying to find one and help him out. thanks
  2. I have one. It was on my 200 while I drove it daily for 2 years, and everything worked fine when I pulled the engine. Only thing is it's a Motorcraft replacement, not the original style Autolite.
  3. How much do you want for it and were there any problems in hooking it up to the linkage? He bought one and it didn't work with his linkage and the guy wouldn't take it back so he's screwed and can't afford to buy another. I'm going to buy this one for him. If you can send me a pic of it so I can compare it with his stock one that would be great. Also figure out a price with shipping to 33510.

    My e-mail address is [email protected].

    I didn't notice you are in lakeland. I am in Brandon so don't sweat shipping I'll pick it up.
  4. I'll take some pics and give you a price when I get off work tomorrow.

    It was on the car when I bought it in 2000, and I drove it for two years, then pulled the engine in 2003. I'm pretty sure it was a stock '66 linkage with the spring that went to the exhaust manifold.
    It was a Mustang Monthly car, and I have a 1997 issue where they took the Motorcraft carb off and put a correct Autolite on; but it had the Motorcraft when I bought it.
  5. Still looking, thanks
Thread Status:
Not open for further replies.