yea umm never heard this noise before

Discussion in 'SN95 4.6L Mustang Tech' started by charlesw6954, Oct 24, 2004.


  1. charlesw6954

    charlesw6954 Founding Member

    Joined:
    May 4, 2002
    Messages:
    478
    Likes Received:
    0
    Trophy Points:
    0
    bought my 00gt in august. first day i had it the battery went dead. they replaced it for free. then when i started running it hard i found out the 2nd gear sychro is gone but they will rebuild it. then it started getting cold outside well one morning i started the car and gave it 5 minutes to warm up then took off to work well i saw the oil pressure gauge was at 0 psi. i was shocked but heard no knocking. now since its getting colder the pressure gauge reads zero ALOT so i bought a new sending unit. was going to install it tonight but when i came home from work i turned car off and usually i would here the exhaust before the engine dies but now i hear a massive knocking when i turn the ignition off. it sounds awful. its got plenty of oil in it. i just did and oil change on it 3 days ago. mobile 1 10w30 so i know the oil aint bad.
  2. jamathi

    jamathi Founding Member

    Joined:
    Aug 19, 2002
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    7
    Is it possible the oil pump is malfunctioning which is resstricting the oil from circulating in the engine? :shrug:
  3. AdRock

    AdRock Member

    Joined:
    Nov 14, 2003
    Messages:
    522
    Likes Received:
    0
    Trophy Points:
    17
    It's not dieseling is it?
  4. charlesw6954

    charlesw6954 Founding Member

    Joined:
    May 4, 2002
    Messages:
    478
    Likes Received:
    0
    Trophy Points:
    0
    i have never owned an engine like this before so i dont know what its suppose to do or how its suppose to run. well ill replace the sending unit and if it keeps going down (pressure) then ford is gonna have to live up to their warranty and probally rebuild my engine and trans while there at it.
  5. drivesideways46

    drivesideways46 New Member

    Joined:
    Feb 17, 2004
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    I've got a 2000 GT as well, and you are supposed to use 5W-30 motor oil in it.
    Sorry to hear about your engine trouble though, hope everything works out on it.

Share This Page