electical

  1. 93CalypsoConvert

    Help With Ignition Problem

    Hello, I'd like to begin with saying this is my first post, so let me know if I'm doing something wrong here. The other day I bought a 1993 Calypso Green convertible and its got some problems I can't quite put my finger on yet. The car was originally a 2.3 5 speed, but the previous owner...
  2. S

    Electrical Need help with unidentified wire connector on 4 cylinder LX

    Found this connector under the front driver’s side fender. It is in the same harness as the windshield washer pump. Any ideas on what it is for? I just noticed the two prongs at the bottom of the reservoir, maybe part of the puzzle?
  3. S

    Electrical 1995 Mustang GT slight hiccups/hesitation at around 2k rpm looking for a fix for the dreaded code 212

    Been working on this issue for months maybe even years now, it’s the same thing every test drive, it runs perfectly except for size varying hiccups and/or hesitations up at around 2k rpm, the code we’ve been receiving all this time has been code 212: loss of IDM (ignition diagnostic monitor)...
  4. 7991LXnSHO

    Electrical Two easy (?) electrical questions

    1. Does anyone have a diagram or picture of where the grounds are located in a 1991 5.0 LX? What about for other years of Fox bodies? I specifically am concerned about Dash ones, but any/all might need inspected after almost 30 years, and I want to prevent the standard Problem with the gauges...
  5. R

    04 Mustang GT Voltage/Electrical Issues

    I'm new here but I needed some help so I figured this would be the right place for that. My '04 recently hit 100k miles and I did some much needed maintenance on her in January mostly due to her giving me starting issues. So I've replaced the spark plugs, battery, starter (that was a pain...
  6. I

    Electrical Hi all! New here! Hoping to get a little help with a problem i am having on my 93 Foxbody!

    Hey guys and gals. I'm having a fuse problem on the fox. Fuse #8 keeps blowing. It blows out as soon as the prongs touch in the fuse box. I can put a bigger fuse in it, (20a 25a) and it will hold untill I crank the car, (turn the engine over) then the bigger fuse will blow. Thought I might be...
  7. N

    42 pin connector

    Hi all! I’m looking for a schematic for the 42 pin connector located on the passenger side of the engine compartment for a 1994 mustang SVS. Does anybody know where I can find one? So far the almighty google has been no help :)
  8. D

    **HELP NEEDED** O2 PIGTAIL WIRES

    O2 Pigtail Was Cut Off, Bought A New One, Was Universal All Black Wires Dont Know Which Wires Connect To Which. Pigtail Was All Black But The O2 Sensor Wires Were 2 White 1 Grey And 1 Black. The pigtail That Came From The Car were White W A Black Stripe, Red W A Yellow stripe, Red W A Green...
  9. D

    No electrical power issue

    I was driving down the highway in my 2002 mustang gt (138k miles) on my way to work when all of the sudden my car lost power. The car cycled on and off very quickly and i was able to drive home. I put the car neutral and let it sit for about an hour. When i tried to start the car again there was...
  10. 69shocktower

    Electrical Bad ignition switch frying starters?

    89 GT 5 spd. First to go, I believe, was the stock ignition coil. Would crank but no fire. Had to tow it home. Drove it fine 2 more days then crank but no fire again. Replaced the coil and I think it started once, has been going on for weeks so cant remember for sure, but then wouldn't crank...
  11. S

    Explorer 5.0 swap

    I have a 4cyl 1990 car and I just bought a 98 explorer with a 5.0 and automatic. how can i get the ecu and harness from the explorer to work? the mustang will have a manual in it so how will i get the ecu from the automatic explorer to work with a t5?
  12. T

    Electrical [1990] Baffling Ignition Issue (Need help ASAP!)

    I am absolutely confused and infuriated with this problem. I have not seen any other threads that describe an issue anything similar to this, so here goes. For the past few days, my car has been starting perfectly fine every time. It has no hesitation starting, and it seemed to run quite well...
  13. 1

    Electrical 1992 5.0 Running rich with surging idle (surge checklist has been done)

    I have been at this problem for months now and I can't seem to find a resolution so I'm hoping the more skilled people here can help before i start spending of money on having someone diagnose so here goes. I have seen several forums on my issue but everything i have tried doesn't seem to fix...
  14. F

    Electrical 1990 5.0 Mustang GT electrical issues

    Hey guys, My 1990 Mustang is having electrical issues. It starts up and ides just fine, But whenever I go over a bumpy road or hit an ok sided bump the car dies. when I go over small ones, the rpm gauge starts dropping and bouncing back up and the lights in the dash dim. However, the headlights...
  15. K

    1968 Brake light problem

    Hi all, new owner of a 1968 mustang Coupe with 289. I'm having an issue where my brake lights aren't coming on. I checked the Brake Light switch at the peddle and it has power. I can confirm the running lights work with the headlights on. Also my right blinker works but not the left (suspect...
  16. Tk469

    Electrical 99 mystery wire

    Found a wire unplugged on my injector harness, any ideas?
  17. FordDawg88

    Electrical 1985 Mustang LX/GT Ignition Coil Wiring Issue

    OK friends I have ran into another wiring issue that I need help with. I have the TFI ignition system with the square ignition coil and when someone connected the wires to the coil they used spade terminals instead of a replacement pigtail. I am now trying to install a new pigtail but the...
  18. J

    Electrical Need Help!!

    Hi all, new to the forums but I’m in great need of assistance. Picked up a 95 5.0 and I have this huge drain on my battery with the key in the ‘run’ position. Not in any other position. Also it’s with the car off, car isn’t running right now because of a fuel pump issue but that’s besides the...
  19. akaNYr

    Rear Defogger Issue

    Hi guys, I got a 1995 GT coupe with a rear defogger problem. The defogger switch light goes on when I activate it but no defogging on the rear windshield. The tabs and connector were dirty & a bit rusty so I cleaned them, still no defogger. I put the multimeter leads to each of the connectors &...