1967 Mustang Brake Light Problem

GaryH

New Member
Sep 15, 2019
4
0
1
67
Australia
Need some help with a Brake light problem on a 67. Power Assisted Drum Brakes all round as standard
At rest brake lights work fine A slight jab of the pedal and on they come BUT as soon as I start driving I need to jump hard on the brakes for them to work. Bloody dangerous as I can't "feather " the pedal to toggle the break lights.
Blinker lights work fine and seem do do what they should
With car running and in park after vacuum booster has done it's job the brake lights work with slightly more pressure than when ignition is off
Emergency Flashers, Blinkers and horn all work fine despite problem I had some 2 years ago or so with the horn as I outline below. I'm not sure if the brake problem presented straight after the horn problem or whether it existed prior or is more recent. Car not driven much and rarely receive feedback on whether brake lights are functioning. Started looking recently after being informed they where not functioning
History
I changed the original steering wheel to a Grant All seemed OK . Some months after changing Steering wheel backed car out of garage to let it run for a while as it had not seen the daylight for around 6 weeks.
Back in garage and noticed a ticking sound when car shutdown. Noticed tick coincided with interior light flickering on and off Quick disconnect of battery and found Grant horn button red hot. Revisited the insulation I had on the horn wiring and all seemed well Horn works etc. Some time later whilst on road informed I had no brake lights Tested at rest and all fine so assumed dirty switch. Problem however has continued _ Brakes test fine at rest but when travelling I have to slam them on to get the brake lights to work. I have changed the brake light switch and no change. Even added a 1/8" plate to the contact area of the switch and found at rest the brake lights stayed on so clearance or play doesn't seem to be the problem and hence removed the additional plate
Only other mod has been to add a small tacho
It's doing my head in - Work at rest but not when on the road travelling along ?????
 
  • Sponsors(?)


2Blue2

will be trying this sex one when I can find it
Mar 5, 2019
1,915
1,100
123
52
Oahu
I'm assuming that it has the original wiring harness?
Brake Light Works at rest when grounds are not shared
Running, grounds are shared.
Old wires and dirty grounds / contacts and battery terminals
Make sure engine and battery are grounded to chassis, and clean all other points of contact
Intermittent problems are the hardest.
Good Luck and post your progress.
 

zookeeper

Founding Member
Aug 25, 2001
3,338
48
109
58
Rogue River, Oregon
Here you go...
 
  • Like
Reactions: 2Blue2

GaryH

New Member
Sep 15, 2019
4
0
1
67
Australia
I'm assuming that it has the original wiring harness?
Brake Light Works at rest when grounds are not shared
Running, grounds are shared.
Old wires and dirty grounds / contacts and battery terminals
Make sure engine and battery are grounded to chassis, and clean all other points of contact
Intermittent problems are the hardest.
Good Luck and post your progress.
Yes all original except Brake light switch now
Thanks all for the insight Still have the problem although I have not gone too far with the investigation other than give some wiring a wriggle !!
Question - If it was an earth problem and seeing many bits share earths when running if I was use a jumper lead to establish another earth on the tail light globe ( I assume the earth is the spade connector on the ring on the globe sticking out of the mounting cup ( Am I correct ??) would this do any damage and if not would it be a pointer to an earth problem??
Guess I am looking for an easy way to start before chasing all the earthing points , removing the steering wheel etc
The replacement brake switch I used was a Scott Drake with no indication of "pressure" It is doing exactly what the original was - Works fine at rest but when travelling have to stomp hard on the pedal for brake lights to work and even then they are sightly delayed in lighting up. Surely there is no correlation between auto transmission gear selection and the brake switch?? Is there??
As mentioned in the first post I placed a 1/8" shim on the switch contact plate which resulted in the brake lights being on permanently at rest Didn't try running VS brake light operation with the shim in place
Also I note that the proportioning valve which I assume would be standard and original to the car has an electrical connection coming out of it from a nylon fitting - can anyone explain it's purpose?? Where does it terminate? Would it affect brake light operation at travelling speeds?
 

zookeeper

Founding Member
Aug 25, 2001
3,338
48
109
58
Rogue River, Oregon
Since the switch is what turns on and off the brake lights, did you even try adjusting it as per the link I posted? Might be worth a try before you go any farther...
 
  • Like
Reactions: 2Blue2

GaryH

New Member
Sep 15, 2019
4
0
1
67
Australia
Since the switch is what turns on and off the brake lights, did you even try adjusting it as per the link I posted? Might be worth a try before you go any farther...
Yes I now have attempted to adjust without any change to my problem I have also been placing various thickness shims on the rod /switch contact surface to minimise the travel distance but problem still exists. I even placed a shim which would have been just under an 1/8" between the contact surfaces and this resulted in the brake lights being on at rest. Run the car at about 5 mph like this and thought if the problem was some sort of short the lights may turn off BUT no they stayed on.
I am at a loss.
What would you think if I disconnected the blinker circuit at the globes and tried the brakes again Might it point to a problem in the turn/brake switching? Would it cause any wiring damage if I made sure any bare ends where well insulated before adding any power?
Could the problem be voltage / regulator related with possibly higher volts with the engine under load causing the problem??
 

zookeeper

Founding Member
Aug 25, 2001
3,338
48
109
58
Rogue River, Oregon
Ok, here's the basics: Never ever put shims in between the space between the brake switch and the push rod. There's no reason to do that ever. At rest the switch should not contact the pushrod. If they aren't coming on at all, or they require too much pedal travel to activate, the tabs and ONLY the tabs need to be bent towards the pushrod. If they're always on, then the tabs need to be bent away from the pushrod. It's that simple.
 
  • Like
Reactions: 2Blue2

GaryH

New Member
Sep 15, 2019
4
0
1
67
Australia
Thanks Zookeeper. I have tried bending the tabs , probably up tp 1/8" forward without success atm . I have cleaned the battery lead at the block end , and had a quick look over the wiring, even disconnected the taco I installed and still no joy. Seems when at rest less pedal travel and I can get the brake lights to toggle. On starting the car and the vacuum booster doing it's thing I have to move the pedal further to toggle the brake lights yet when I start moving NO brake lights until approx 1 second after the car comes to rest. I ran the car at dusk with the lights on ( using wife as a spotter - yeah I know first mistake !!) and still no change to brake light operation ie OK at rest and not coming on till car has stopped after rolling down the road. Wife reckons no change in brightness of lights when they did come on with headlights turned on , although I do notice a change when stopped in the garage with and without engine running. I will continue bending the tabs until I reach the point of lights permanently on the back off a bit to the not on spot. Question - Is the flat on the rod long enough to meet the tabs before the centre of the switch? ie will the rod flat miss the tabs even if they are bent? Went to get a relative measure last time under but couldn't quite get it accurately that time
Anything else anyone could suggest I check?
What about disconnecting the blinkers to see if the problem lies in the cut out switch between blinkers and brake lights, although it works perfectly at rest
Thanks in advance
 
Thread starter Similar threads Forum Replies Date
R 1967 Mustang Disc Brake Swap Question 1965 - 1973 Classic Mustangs -General/Talk- 2
M Ok All You Power Brake Gurus I Have A Big Problem! With My 1967 Mustang, Please Help 1965 - 1973 Classic Mustangs -General/Talk- 8
R 1967 Mustang power brake conversion Classic Mustang Specific Tech 4
J Front Brakes - 1967 Mustang Classic Mustang Specific Tech 11
derek2079 For Sale 1967 Mustang Radiator Original Engine and Power Adder 0
C Interior swap for 1967 mustang 1965 - 1973 Classic Mustangs -General/Talk- 2
A 1967 Mustang decoding Buck plate The Welcome Wagon 2
derek2079 For Sale 1967 Mustang Radiator OEM Classic Mustangs For Sale 0
D 1967 mustang 289 V8 headers 1965 - 1973 Classic Mustangs -General/Talk- 2
T 1974 F-100 9" in a 1967 Mustang coupe 1965 - 1973 Classic Mustangs -General/Talk- 1
J Engine 302 Roller Build Fox Engine Swaparoo 2
T 1967 Mustang Coupe 5-speed swap 1965 - 1973 Classic Mustangs -General/Talk- 13
Mattster_ '67 Mustang 289 Cooling issue. 1965 - 1973 Classic Mustangs -General/Talk- 3
M 1967 Mustang Coupe - 17" Wheel backspacing 1965 - 1973 Classic Mustangs -General/Talk- 0
K What's it Worth? Seeking rough valuation on manual 1967 Coupe w/ 351 Windsor What is it Worth?!?!? 2
J Wheels-Tires 1967 coupe with 8.8 inch rear end Classic Mustang Specific Tech 0
Alec21 1967 coupe, bogging down problem Classic Mustang Specific Tech 9
J-Scratch 1967 MUSTANG WHEELS - 18" Vision 142 Legend Rims 1965 - 1973 Classic Mustangs -General/Talk- 0
I 1967 Mustang won't start and buzzing noise 1965 - 1973 Classic Mustangs -General/Talk- 4
Karl Fabian 1967 Mustang Door Speakers And Courtesy Lights Location? Mustang Sound & Shine All 0
L "eleanore" Shelby Mustang Gt500 1967 1965 - 1973 Classic Mustangs -General/Talk- 4
D 1967 Mustang Gt Interior 1965 - 1973 Classic Mustangs -General/Talk- 0
Joejoejoe I Need Help, I Am About To Buy A 1967 Mustang 1965 - 1973 Classic Mustangs -General/Talk- 19
0 Expired 1967 Mustang Seats Interior Exterior Parts 0
bluelx347 SOLD 1967 Ford Mustang Hood Interior Exterior Parts 0
bluelx347 Expired 1967 Mustang 3 Speek Transmission Drivetrain Parts 0
M Expired 2014 F150 Coyote Engine Other Classifieds 0
K Barn Find 1967 S-code SN95 4.6L Mustang Tech 0
M 1967 Mustang Rear End 1965 - 1973 Classic Mustangs -General/Talk- 3
M 1967 Rear End Classic Mustang Specific Tech 2
P My First Car 1967 Mustang Fastback The Welcome Wagon 3
J 1967 Mustang 1965 - 1973 Classic Mustangs -General/Talk- 2
E Can Someone Tell Me Which Engine This Is? 1965 - 1973 Classic Mustangs -General/Talk- 2
mentalward Help Assessing Value Of 1967 Mustang Coupe The Welcome Wagon 4
automart7 1967 Ford Mustang Gt 390 Overheating Classic Mustang Specific Tech 0
P 1967 Mustang C Code Coupe Value 1965 - 1973 Classic Mustangs -General/Talk- 6
67ultrasonic 1967 Mustang Restomod Build The Welcome Wagon 5
S 1967 Mustang Alternator Charging Problem 1965 - 1973 Classic Mustangs -General/Talk- 0
J Problem With My 1967 Mustang With A 390 1965 - 1973 Classic Mustangs -General/Talk- 6
B Rare 1967 Mustang Emblem "sports Sprint" 1965 - 1973 Classic Mustangs -General/Talk- 7
S Need Center A/c Register For 67 Mustang The Welcome Wagon 2
mustangguy65 1967 Ford Mustang Center Console 1965 - 1973 Classic Mustangs -General/Talk- 2
66fstbk Expired 1967 Fastback Gta 390 - Roller - Norcal Classic Mustangs For Sale 0
G Expired 1967 Mustang Coupe/dark Blue/saddle Interior/original 289 C Classic Mustangs For Sale 0
Gulf67 New 2 Stangnet, Long Time Mustang Guy. 1967 Mustang The Welcome Wagon 1
MRaburn Youtube Mustang T5 5-speed Transmission Conversion Installation 1967 StangNet Site News 0
D Expired 1967 Ford Mustang Fastback - Fully Restored - 5speed Classic Mustangs For Sale 6
A SOLD 1967 Mustang Gta Coupe, S-code Classic Mustangs For Sale 5
1 Using A 1998 Mustang Gt As Donor Car For 1967 Mustang Coupe 1965 - 1973 Classic Mustangs -General/Talk- 1
T Expired 1967 Ford Mustang Convertible - $24900 Classic Mustangs For Sale 0
Similar threads